New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

device type not being set for any new devices #5412

Closed
sysmonk opened this Issue Jan 12, 2017 · 3 comments

Comments

Projects
None yet
2 participants
@sysmonk
Contributor

sysmonk commented Jan 12, 2017

DO NOT DELETE THIS INFORMATION.

Please read this information carefully.

GitHub issues is for feature requests or bugs, please do not post issues asking for help or how to do X, Y or Z.
You can use our irc channel ##librenms on freenode to ask questions or our community site.

Please confirm each of the sections below by putting an x in the box like [x].

  • Is your install up to date? Updating your install
    Please do not submit an issue if your install is not up to date within the last 24 hours or on a stable monthly release.
  • Please include all of the information between the ==================================== section of ./validate.php which you can run from the cli.
  • Unless your issue is for a WebUI fix or feature then please provide ALL info asked for here.
  • Please provide as much detail as possible.

==========================================================
Component | Version
--------- | -------
LibreNMS | 78cdca0
DB Schema | 153
PHP | 7.0.14-1~dotdeb+8.1
MySQL | 10.0.28-MariaDB-0+deb8u1
RRDTool | 1.4.8
SNMP | NET-SNMP 5.7.2.1

Librenms stopped setting the device type for new devices added recently. This sounds related to https://github.com/librenms/librenms/blob/master/includes/common.php#L1529 - it's sets the type (and makes any later checks not see that it changed), but does not update the db.

@laf

This comment has been minimized.

Show comment
Hide comment
@laf

laf Jan 12, 2017

Member

The type setting isnt done there. It's done here. https://github.com/librenms/librenms/blob/master/includes/discovery/os.inc.php

Please post output onto pastebin for ./discovery.php -h HOSTNAME -d -m os

Member

laf commented Jan 12, 2017

The type setting isnt done there. It's done here. https://github.com/librenms/librenms/blob/master/includes/discovery/os.inc.php

Please post output onto pastebin for ./discovery.php -h HOSTNAME -d -m os

@laf

This comment has been minimized.

Show comment
Hide comment
@laf

laf Jan 12, 2017

Member

Actually don't need this, confirmed, fix being done.

Member

laf commented Jan 12, 2017

Actually don't need this, confirmed, fix being done.

laf added a commit to laf/librenms that referenced this issue Jan 12, 2017

@murrant murrant closed this in #5414 Jan 13, 2017

murrant added a commit that referenced this issue Jan 13, 2017

fix: Detection blank or unknown device types and update #5412 (#5414)
* fix: Detection blank or unknown device types and update #5412

* Less ifs
@lock

This comment has been minimized.

Show comment
Hide comment
@lock

lock bot May 18, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed.

lock bot commented May 18, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed.

@lock lock bot locked as resolved and limited conversation to collaborators May 18, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.