New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

APC UPS support seems to have been removed? #5428

Closed
rbax82 opened this Issue Jan 14, 2017 · 4 comments

Comments

Projects
None yet
3 participants
@rbax82
Contributor

rbax82 commented Jan 14, 2017

APC UPS support seems to have been removed as an application from the webUI. Could it please be put back in?

https://github.com/librenms/librenms-agent/blob/master/snmp/ups-apcups.sh is there and yet the application doesn't appear to be an option in the librenms webUI.

DO NOT DELETE THIS INFORMATION.

Please read this information carefully.
GitHub issues is for feature requests or bugs, please do not post issues asking for help or how to do X, Y or Z.
You can use our irc channel ##librenms on freenode to ask questions or our community site.

Is your install up to date? Updating your install
Please do not submit an issue if your install is not up to date within the last 24 hours or on a stable monthly release.
Please include all of the information between the ==================================== section of ./validate.php.
If you would like us to add a new device or your device is listed as Generic then please provide the information asked for here
Please provide as much detail as possible.

@laf

This comment has been minimized.

Show comment
Hide comment
@laf

laf Jan 15, 2017

Member

I don't think it's ever been in the list to select from:

https://github.com/librenms/librenms/commits/master/html/pages/device/edit/apps.inc.php

Seems to indicate it's not been removed in the last 12 months.

Member

laf commented Jan 15, 2017

I don't think it's ever been in the list to select from:

https://github.com/librenms/librenms/commits/master/html/pages/device/edit/apps.inc.php

Seems to indicate it's not been removed in the last 12 months.

@Compizfox

This comment has been minimized.

Show comment
Hide comment
@Compizfox

Compizfox Jan 15, 2017

@laf That's correct. As explained in #4818, there is an agent script for it. The documentation instructs you to enable the ups-apcups application in the web interface, but it is not there.

Compizfox commented Jan 15, 2017

@laf That's correct. As explained in #4818, there is an agent script for it. The documentation instructs you to enable the ups-apcups application in the web interface, but it is not there.

@crcro crcro referenced this issue Jan 16, 2017

Merged

fix: ups-apcups #5452

2 of 2 tasks complete

laf added a commit that referenced this issue Jan 16, 2017

@laf laf closed this Jan 16, 2017

@Compizfox

This comment has been minimized.

Show comment
Hide comment
@Compizfox

Compizfox Jan 16, 2017

Thanks, seems to work (over SNMP too)!

EDIT: Except for one small thing: the string returned from snmp_get is wrapped in quotes. This causes the first and last field (current line voltage and nominal battery voltage) not to be parsed correctly.

This can be fixed by trimming the quotes from the string:

$ups_apcups = trim(snmp_get($device, $oid, '-Oqv'), '"');

Compizfox commented Jan 16, 2017

Thanks, seems to work (over SNMP too)!

EDIT: Except for one small thing: the string returned from snmp_get is wrapped in quotes. This causes the first and last field (current line voltage and nominal battery voltage) not to be parsed correctly.

This can be fixed by trimming the quotes from the string:

$ups_apcups = trim(snmp_get($device, $oid, '-Oqv'), '"');

@crcro crcro referenced this issue Jan 16, 2017

Merged

fix: ups-apcups #5473

2 of 2 tasks complete
@lock

This comment has been minimized.

Show comment
Hide comment
@lock

lock bot May 18, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed.

lock bot commented May 18, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed.

@lock lock bot locked as resolved and limited conversation to collaborators May 18, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.