New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

SNMP contact is not updated in webgui when removed from the device. #5811

Closed
eikik87 opened this Issue Feb 7, 2017 · 1 comment

Comments

Projects
None yet
2 participants
@eikik87

eikik87 commented Feb 7, 2017

DO NOT DELETE THIS INFORMATION.

Please read this information carefully.

GitHub issues is for bugs, please do not post issues asking for help or how to do X, Y or Z.
You can use our irc channel ##librenms on freenode to ask questions or our community site.
If you have a feature request please post this on our community site.

Please confirm each of the sections below by putting an x in the box like [x].

  • [ x] Is your install up to date? Updating your install
    Please do not submit an issue if your install is not up to date within the last 24 hours or on a stable monthly release.
  • [ x] Please include all of the information between the ==================================== section of ./validate.php which you can run from the cli.
  • [ x] Please provide ALL info asked for here.
  • [x ] Please provide as much detail as possible.
  • [x ] Please do NOT post more than 10 lines of debug information here, use a pastebin service or GitHub Gists.

==========================================================
Component | Version
--------- | -------
LibreNMS | 5aef36a
DB Schema | 159
PHP | 5.5.9-1ubuntu4.20
MySQL | 5.5.54-0ubuntu0.14.04.1
RRDTool | 1.4.7
SNMP | NET-SNMP 5.7.2

http://pastebin.com/UG8DkNHj

I have a Cisco router.

I put in this command - "snmp-server contact none@none.com"

After running debug command "./discovery.php -m sensors -h HOSTNAME -d" I get the contact instantly into the webgui.

But when I remove the contact, it does not get updated and the old 'none@none.com' contact is stuck. And only way I can "remove" it, is by putting in some random words.

This might be issue as I'm planning on having email of our customer and if they would not want to have email anymore, I would remove this contact command from the device. Instead of having librenms trying to send email to random words I put into the contacts. It would be better to have it empty.

@lock

This comment has been minimized.

Show comment
Hide comment
@lock

lock bot May 17, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed.

lock bot commented May 17, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed.

@lock lock bot locked as resolved and limited conversation to collaborators May 17, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.