New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Notifications by email to admins isn't working when using Active Directory authentication #6134

Closed
FTBZ opened this Issue Mar 8, 2017 · 3 comments

Comments

Projects
None yet
2 participants
@FTBZ
Contributor

FTBZ commented Mar 8, 2017

Please confirm each of the sections below by putting an x in the box like [x].

  • Is your install up to date? Updating your install
    Please do not submit an issue if your install is not up to date within the last 24 hours or on a stable monthly release.
Component Version
LibreNMS 1c48fe3
DB Schema 173
PHP 7.0.11
MySQL 5.5.50-MariaDB
RRDTool 1.4.8
SNMP NET-SNMP 5.7.2

When trying to send mails notifications to admins users that are using Active Directory authentication, I noticed that was not working. Based on the @laf debugging by IRC it's seems to be not possible.

unknown

Debug code:

$init_modules = ['alerts'];
include '/opt/librenms/includes/init.php';

print_r(get_userlist());

Using this code returns an empty array even if the alerts capture debug is returning the correct informations.

@laf laf added the Alerting 🔔 label Mar 9, 2017

@FTBZ

This comment has been minimized.

Show comment
Hide comment
@FTBZ

FTBZ Mar 10, 2017

Contributor

Not sure that's related to AD, because sysContact isn't working too...

Contributor

FTBZ commented Mar 10, 2017

Not sure that's related to AD, because sysContact isn't working too...

@laf

This comment has been minimized.

Show comment
Hide comment
@laf

laf Mar 10, 2017

Member

It is related to AD, we can't auth to get user emails for AD so that will absolutely not work right now.

Member

laf commented Mar 10, 2017

It is related to AD, we can't auth to get user emails for AD so that will absolutely not work right now.

@FTBZ FTBZ referenced this issue Mar 27, 2017

Merged

feature: bind user for active_directory auth #6255

2 of 2 tasks complete

@murrant murrant closed this in #6255 Mar 29, 2017

@lock

This comment has been minimized.

Show comment
Hide comment
@lock

lock bot May 17, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed.

lock bot commented May 17, 2018

This thread has been automatically locked since there has not been any recent activity after it was closed.

@lock lock bot locked as resolved and limited conversation to collaborators May 17, 2018

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.