Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[feat] edgeos hardware info #9867

Merged
merged 6 commits into from Mar 1, 2019

Conversation

Projects
None yet
2 participants
@crcro
Copy link
Contributor

commented Feb 24, 2019

  • added missing hardware info
  • cleanup os version

(tested with v2.0.0 of edgeos and edge router pro)

before:
screen shot 2019-02-24 at 8 46 47 pm

after:
screen shot 2019-02-24 at 8 47 52 pm

DO NOT DELETE THIS TEXT

Please note

Please read this information carefully. You can run ./scripts/pre-commit.php to check your code before submitting.

Testers

If you would like to test this pull request then please run: ./scripts/github-apply <pr_id>, i.e ./scripts/github-apply 5926
After you are done testing, you can remove the changes with ./scripts/github-remove. If there are schema changes, you can ask on discord how to revert.

crcro and others added some commits Feb 24, 2019

added hardware info
cleanup os version
@PipoCanaja

This comment has been minimized.

Copy link
Contributor

commented Feb 25, 2019

Hi @crcro
Could you:

  • update your local repo using git pull origin edgeos_hw_info
  • check that it still works as expected
  • run ./scripts/collect-snmp-data.php -h <yourDevice>
  • run ./scripts/save-test-data.php -o edgeos
  • run git add tests/data/edgeos.json
  • run git commit -a -m 'Updated test data'
  • run git push origin edgeos_hw_info
    Thanx ;)
    PipoCanaja

@PipoCanaja PipoCanaja self-assigned this Feb 25, 2019

@crcro

This comment has been minimized.

Copy link
Contributor Author

commented Feb 26, 2019

Hi @PipoCanaja,

it works with your changes.
I cannot save test data, the scripts save-test-data.php is freezing with:

--- Transport configuration
Listening at UDP/IPv4 endpoint 127.1.6.1:1161, transport ID 1.3.6.1.6.1.1.0

@PipoCanaja

This comment has been minimized.

Copy link
Contributor

commented Feb 26, 2019

Hi @crcro
Do you have by chance a Firewall running on your device ? You can confirm this by disabling it temporarily and testing. If the issue is solved, you should probably disable it for any loopback traffic (means 127.0.0.0/8) and not only 127.0.0.1 as most of us always use for loopback ...

@PipoCanaja

This comment has been minimized.

Copy link
Contributor

commented Feb 26, 2019

What you can do for sure is "git add" the edgeos.snmprec file to this PR.

@PipoCanaja

This comment has been minimized.

Copy link
Contributor

commented Feb 28, 2019

Hi @crcro
Did you manage to disable the firewall so you can run save-test-data as well ?

@PipoCanaja
Copy link
Contributor

left a comment

LGTM

@PipoCanaja PipoCanaja merged commit 3ad698f into librenms:master Mar 1, 2019

6 checks passed

Inspection Summary
Details
Node: analysis
Details
Travis CI - Pull Request Build Passed
Details
WIP Ready for review
Details
codeclimate All good!
Details
license/cla Contributor License Agreement is signed.
Details

@lock lock bot locked as resolved and limited conversation to collaborators Apr 30, 2019

Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
You can’t perform that action at this time.