New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[Vulkan][Ubuntu] Bad Sector error when running mednafen_psx(sw,gl,vulkan) #158

Open
retro-wertz opened this Issue Feb 6, 2017 · 4 comments

Comments

Projects
None yet
4 participants
@retro-wertz
Copy link
Contributor

retro-wertz commented Feb 6, 2017

First and foremost consider this:

Only RetroArch bugs should be filed here. Not core bugs or game bugs
This is not a forum or a help section, this is strictly developer oriented

Description

[Description of the bug]
When using vulkan video drivers in retroarch, mednafen_psx gets stuck at Playstation boot screen and displays Bad sector error(tried mednafen_psx and mednafen_psx_hw).

Expected behavior

[What you expected to happen]
Game should load or run.

Actual behavior

with retroarch using vulkan drivers, when you load a game using mednafen_psx software or hw core, it just gets stuck at PS boot screen with bad sector notice.

Steps to reproduce the bug

run retroarch
select vulkan driver
close retroarch
run retroarch
choose a psx game
select mednafen psx core / mednafen psx hw core
*** Bad sector? 2 ***
Bisect Results

[Try to bisect and tell us when this started happening]

-using the same steps above to reproduce bug but set retroarch to use opengl drivers does not cause bad sector issue with mednafen_psx or mednafen_psx_hw.
-cd image are redump verified(cue is is renamed for easier loading in retroarch-avoid that name scrolling with long text lines)
-there has been talks in forums and other sources of such issue when using vulkan in retroarch. i even offered a HAVE_CDROM_NEW compiled mednafan_psx core and they still it still displays bad sector. that time i thought it was just a bad translation game, since i do not a way to test vulkan yet.
-tested only in ubuntu since it can load vulkan drivers for my gpu, my windows box do not have vulkan to test and compare.

logs:
retroarch_vulkan/psx_software : https://hastebin.com/ejoqoyajon.sql
retroarch_vulkan/psx_vulkan : https://hastebin.com/elohubirec.sql

retroarch_opengl/psx_software : https://hastebin.com/epogumiwiq.sql
retroarch_opengl/psx_vulkan : https://hastebin.com/eyunadujon.sql

Version/Commit

RA_VERSION : 1.4.1 593d1ff
MEDNAFEN_VERSION : e3aae3d

Environment information

OS: Ubuntu 16.10
Compiler: gcc version 6.2.0 20161005 (Ubuntu 6.2.0-5ubuntu12)

@upwhatever

This comment has been minimized.

Copy link

upwhatever commented Feb 24, 2017

Did you try to enable "CD Image Cache"? I think I suffered from the same problem some weeks ago and it disappeared by setting this to "on".

@retro-wertz

This comment has been minimized.

Copy link
Contributor Author

retro-wertz commented Feb 24, 2017

@hizzlekizzle

This comment has been minimized.

Copy link
Member

hizzlekizzle commented Feb 24, 2017

Yeah, Twinaphex has been suffering from this for a long time but hasn't been able to figure out the cause. It only happens with X11, as well. Wayland doesn't have it.

@i30817

This comment has been minimized.

Copy link

i30817 commented Aug 4, 2017

Which game? Because this is pretty normal on misapplied translations or even in some few badly made translations (that then can get fixed with a tool like error_recalc )

Just now i had various 'bad sector' errors in Akumajou Dracula X (symphony of the night japan) translation. It was because the readme had 'apply this to the first edition' but redump had the brilliant idea of naming the 'first edition' version 1.2. I thought it was just broken on the emulator when i tried error_recalc on top of the translated track and it still gave the blackscreen, minus the bad sector warnings on standalone mednafen, but no, it was actually the version.

@twinaphex twinaphex changed the title [Vulkan][Ubuntu]Bad Sector error when running mednafen_psx(sw,gl,vulkan) [Vulkan][Ubuntu] Bad Sector error when running mednafen_psx(sw,gl,vulkan) Jul 23, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment