Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Soldier of Fortune - Enemy AI appears broken #127

Closed
twinaphex opened this Issue Jul 6, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@twinaphex
Copy link
Member

twinaphex commented Jul 6, 2018

The enemy AI is completely broken in this game, and they just seem to rotate around while not really moving around. This seems to happen to the NPCs in the intro sequence as well.

@flyinghead

This comment has been minimized.

Copy link
Collaborator

flyinghead commented Jul 8, 2018

I was lucky on this one but still, it was really painful to narrow it down. See flyinghead@efa145f for a fix.
Not sure what would be the equivalent compiler flag in MSVC. One option is to set the floating point model to precise for the files core/hw/sh4/dyna/shil.cpp and core/hw/sh4/interpr/sh4_fpu.cpp. Not sure about the performance hit though.

@twinaphex

This comment has been minimized.

Copy link
Member Author

twinaphex commented Jul 8, 2018

Awesome, this fixes things indeed!

@twinaphex twinaphex closed this Jul 8, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.
You signed in with another tab or window. Reload to refresh your session. You signed out in another tab or window. Reload to refresh your session.