Skip to content
Permalink
Browse files

Fixed bug 4154 - Fix three empty variable tests in configure

Zack Middleton

Running top-level SDL configure on macOS 10.11 resulted in the errors below because automake removed the brackets about the tests.

./configure: line 15756: : command not found
./configure: line 15759: -Iinclude -I/Users/zack/SDL/include -idirafter /Users/zack/SDL/src/video/khronos : No such file or directory
./configure: line 15763: : command not found
  • Loading branch information
slouken committed May 5, 2018
1 parent 606c5a5 commit 0bade9b411c71b21a449a0e493247dfa0a97d86a
Showing with 6 additions and 6 deletions.
  1. +3 −3 configure
  2. +3 −3 configure.in
@@ -15753,14 +15753,14 @@ EXTRA_LDFLAGS="$BASE_LDFLAGS"
#done
SDL_CFLAGS="$BASE_CFLAGS"
SDL_LIBS="-lSDL2"
if "$BASE_LDFLAGS" != "" ; then
if test "x$BASE_LDFLAGS" != x; then
SDL_LIBS="$SDL_LIBS $BASE_LDFLAGS"
fi
if "$EXTRA_CFLAGS" != "" ; then
if test "x$EXTRA_CFLAGS" != x; then
CPPFLAGS="$CPPFLAGS $EXTRA_CFLAGS"
CFLAGS="$CFLAGS $EXTRA_CFLAGS"
fi
if "$EXTRA_LDFLAGS" != "" ; then
if test "x$EXTRA_LDFLAGS" != x; then
LDFLAGS="$LDFLAGS $EXTRA_LDFLAGS"
fi

@@ -124,14 +124,14 @@ EXTRA_LDFLAGS="$BASE_LDFLAGS"
#done
SDL_CFLAGS="$BASE_CFLAGS"
SDL_LIBS="-lSDL2"
if [ "$BASE_LDFLAGS" != "" ]; then
if test "x$BASE_LDFLAGS" != x; then
SDL_LIBS="$SDL_LIBS $BASE_LDFLAGS"
fi
if [ "$EXTRA_CFLAGS" != "" ]; then
if test "x$EXTRA_CFLAGS" != x; then
CPPFLAGS="$CPPFLAGS $EXTRA_CFLAGS"
CFLAGS="$CFLAGS $EXTRA_CFLAGS"
fi
if [ "$EXTRA_LDFLAGS" != "" ]; then
if test "x$EXTRA_LDFLAGS" != x; then
LDFLAGS="$LDFLAGS $EXTRA_LDFLAGS"
fi

0 comments on commit 0bade9b

Please sign in to comment.