Skip to content
Permalink
Browse files

winrt: Disabled Windows Phone 8.0 builds.

It lacks APIs we need for WASAPI and probably no one will miss it. 8.1 is
still supported.
  • Loading branch information
icculus committed Dec 31, 2017
1 parent 791c0dd commit c0c3056948ad99c06a1de09a8dcf4ce93ce12c84
Showing with 4 additions and 2 deletions.
  1. +4 −2 build-scripts/winrtbuild.ps1
@@ -211,9 +211,11 @@ function Build-SDL-WinRT-Variant
$DidAnyDLLBuildFail = $false
$DidAnyNugetBuildFail = $false

# Ryan disabled WP8.0, because it doesn't appear to have mmdeviceapi.h that SDL_wasapi needs.
# My assumption is that no one will miss this, but send patches otherwise! --ryan.
# Build for Windows Phone 8.0, via VC++ 2012:
if ( ! (Build-SDL-WinRT-Variant "SDL" "v110_wp80" "ARM")) { $DidAnyDLLBuildFail = $true }
if ( ! (Build-SDL-WinRT-Variant "SDL" "v110_wp80" "Win32")) { $DidAnyDLLBuildFail = $true }
#if ( ! (Build-SDL-WinRT-Variant "SDL" "v110_wp80" "ARM")) { $DidAnyDLLBuildFail = $true }
#if ( ! (Build-SDL-WinRT-Variant "SDL" "v110_wp80" "Win32")) { $DidAnyDLLBuildFail = $true }

# Build for Windows Phone 8.1, via VC++ 2013:
if ( ! (Build-SDL-WinRT-Variant "SDL" "v120_wp81" "ARM")) { $DidAnyDLLBuildFail = $true }

0 comments on commit c0c3056

Please sign in to comment.