Skip to content
Permalink
Browse files
Fixed bug 5075 - Don't assume a GL library version number on NetBSD.
Nia Alarie

If you install X as part of NetBSD, the GL library is libGL.so.3, but if you install the GL library later as a package, it's libGL.so.1.
  • Loading branch information
slouken committed Apr 5, 2020
1 parent d4b561f commit e05d92a17db7105c352fce001619f5fea0ed540e
Showing with 6 additions and 2 deletions.
  1. +6 −2 src/video/x11/SDL_x11opengl.c
@@ -32,8 +32,12 @@
#include "SDL_loadso.h"
#include "SDL_x11opengles.h"

#if defined(__IRIX__)
/* IRIX doesn't have a GL library versioning system */
#if defined(__IRIX__) || defined(__NetBSD__)
/*
* IRIX doesn't have a GL library versioning system.
* NetBSD has different GL library versions depending on how the library was
* installed (package vs. xsrc).
*/
#define DEFAULT_OPENGL "libGL.so"
#elif defined(__MACOSX__)
#define DEFAULT_OPENGL "/opt/X11/lib/libGL.1.dylib"

0 comments on commit e05d92a

Please sign in to comment.