Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

2.0.8 regression: most apps stopped working on Wayland #2847

Closed
SDLBugzilla opened this issue Feb 11, 2021 · 0 comments
Closed

2.0.8 regression: most apps stopped working on Wayland #2847

SDLBugzilla opened this issue Feb 11, 2021 · 0 comments

Comments

@SDLBugzilla
Copy link
Collaborator

@SDLBugzilla SDLBugzilla commented Feb 11, 2021

This bug report was migrated from our old Bugzilla tracker.

Reported in version: HG 2.1
Reported for operating system, platform: FreeBSD, x86_64

Comments on the original bug report:

On 2018-03-14 19:41:31 +0000, wrote:

With 2.0.7, I can run all applications with SDL_VIDEODRIVER=wayland.

With 2.0.8, most of them don't show their windows, and output this message:

zxdg_surface_v6@23: error 3: xdg_surface has never been configured

(For example, Dungeon Crawl Stone Soup, simple examples https://gist.github.com/exavolt/2360410 https://gist.github.com/olevegard/e1ce53d9302c4ed3be8d and Blender built with experimental SDL backend failed like that, but Cataclysm: Dark Days Ahead works fine even on 2.0.8)

On 2018-03-14 19:52:23 +0000, Ryan C. Gordon wrote:

This is my bug.

—ryan.

On 2018-04-03 01:57:59 +0000, Ryan C. Gordon wrote:

*** Bug 4119 has been marked as a duplicate of this bug. ***

On 2018-04-15 22:38:54 +0000, Ryan C. Gordon wrote:

This should be fixed by https://hg.libsdl.org/SDL/rev/295cf9910d75, but I confess, I couldn't trigger this bug with any of the example programs mentioned, but that could be the dumb luck of process scheduling.

Please try the latest in Mercurial when you get a moment and let me know if the problem is fixed for you!

Thanks,
--ryan.

On 2018-04-16 11:49:08 +0000, wrote:

Yes, everything seems to work fine now in latest hg!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
None yet
Projects
None yet
Development

No branches or pull requests

1 participant