Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

ogg clicks when looping as music on windows #73

Closed
SDLBugzilla opened this issue Feb 11, 2021 · 0 comments
Closed

ogg clicks when looping as music on windows #73

SDLBugzilla opened this issue Feb 11, 2021 · 0 comments

Comments

@SDLBugzilla
Copy link
Collaborator

SDLBugzilla commented Feb 11, 2021

This bug report was migrated from our old Bugzilla tracker.

Reported in version: unspecified
Reported for operating system, platform: Windows (All), x86

Comments on the original bug report:

On 2009-10-12 14:25:54 +0000, Rene Dudfield wrote:

"We're having another subtle issue, this time with SDL_Mixer. We have a 24-second, 44.1 KHz stereo ogg loop which we play as music with Mix_PlayMusic(pChunk, 0) to make it loop indefinitely.

At least on Windows, when the music loops, we start hearing a quick clicking noise on top of the music, which never goes away. Since the first pass sounds perfect and the ogg sounds perfect in, say, mplayer, I guess it's a SDL_Mixer issue."

A work around is to play the music, wait until it finishes, and then play it again.

Can not reproduce on ubuntu with ./build/playmus -i -l bla.ogg

On 2009-10-15 23:10:57 +0000, Sam Lantinga wrote:

Can you reproduce this with the snapshot DLLs here:
http://www.libsdl.org/tmp/SDL-1.2-mingw32.zip

See ya!

On 2011-12-31 11:03:43 +0000, Sam Lantinga wrote:

No response in a couple years, closing this out.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Development

No branches or pull requests

1 participant