New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Testing dependency on HTML::Parser [rt.cpan.org #50440] #214

Closed
oalders opened this Issue Mar 31, 2017 · 2 comments

Comments

Projects
None yet
3 participants
@oalders
Member

oalders commented Mar 31, 2017

Migrated from rt.cpan.org#50440 (status was 'open')

Requestors:

From dave@sherohman.org on 2009-10-13 13:48:16:

libwww-perl-5.833's base/message-charset test script depends on
HTML::Parser, preventing (non-forced) installation of this package
unless HTML::Parser has been previously installed.

HTML::Parser should be added to libwww-perl as a dependency or the
base/message-charset tests should be skipped if it is not present.

From gaas@cpan.org on 2009-10-13 15:05:57:

http://cpansearch.perl.org/src/GAAS/libwww-perl-5.833/META.yml do list HTML::Parser as a 
dependency.  The source of this is the PREREQ_PM entries in the Makefile.PL.

From dave@sherohman.org on 2009-10-13 15:18:07:

On Tue, Oct 13, 2009 at 11:05:59AM -0400, Gisle_Aas via RT wrote:
> <URL: https://rt.cpan.org/Ticket/Display.html?id=50440 >
> 
> http://cpansearch.perl.org/src/GAAS/libwww-perl-5.833/META.yml do list HTML::Parser as a 
> dependency.  The source of this is the PREREQ_PM entries in the Makefile.PL.

That's odd, then...  Immediately prior to filing the bug report, I
attempted to update LWP and the install failed due to:

base/message-charset......1/21 Can't locate auto/HTML/Parser/utf8_mode.al in @IN
C (@INC contains: ../blib/lib ../blib/arch ../. /System/Library/Perl/5.8.6/darwi
n-thread-multi-2level /System/Library/Perl/5.8.6 /Library/Perl/5.8.6/darwin-thre
ad-multi-2level /Library/Perl/5.8.6 /Library/Perl /Network/Library/Perl/5.8.6/da
rwin-thread-multi-2level /Network/Library/Perl/5.8.6 /Network/Library/Perl /Syst
em/Library/Perl/Extras/5.8.6/darwin-thread-multi-2level /System/Library/Perl/Ext
ras/5.8.6 /Library/Perl/5.8.1 .) at /System/Library/Perl/Extras/5.8.6/darwin-thr
ead-multi-2level/HTML/Parser.pm line 82

Doing an 'install HTML::Parser', then trying again to 'install
LWP::UserAgent' resolved the.  Possibly a too-old HTML::Parser on my
part, then?

My perl is:

$ perl -V
Summary of my perl5 (revision 5 version 8 subversion 6) configuration:
  Platform:
    osname=darwin, osvers=8.0, archname=darwin-thread-multi-2level
    uname='darwin b45.apple.com 8.0 darwin kernel version 8.8.4: sun oct 29 15:30:27 pst 2006; root:xnu-792.16.4.obj~1release_ppc power macintosh powerpc '
...
Characteristics of this binary (from libperl): 
  Compile-time options: MULTIPLICITY USE_ITHREADS USE_LARGE_FILES PERL_IMPLICIT_CONTEXT
  Locally applied patches:
        23953 - fix for File::Path::rmtree CAN-2004-0452 security issue
        33990 - fix for setuid perl security issues
        fix for regcomp CVE-2007-5116 security vulnerability
        fix for double-free CVE-2008-1927 security vulnerability
        SPRINTF0 - fixes for sprintf formatting issues - CVE-2005-3962
  Built under darwin
@colinnewell

This comment has been minimized.

Show comment
Hide comment
@colinnewell

colinnewell Apr 12, 2017

Contributor

HTML::HeadParser (which is in HTML::Parser) is a core dependency so this doesn't look like it should be an issue now.

Contributor

colinnewell commented Apr 12, 2017

HTML::HeadParser (which is in HTML::Parser) is a core dependency so this doesn't look like it should be an issue now.

@genio

This comment has been minimized.

Show comment
Hide comment
@genio

genio Apr 12, 2017

Member

Closing out for now. If there's a need to reopen it, please yell at me.

Member

genio commented Apr 12, 2017

Closing out for now. If there's a need to reopen it, please yell at me.

@genio genio closed this Apr 12, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment