Browse files

package: remove the 'preinstall' and 'install' scripts

This way, older versions of npm (that don't bundle node-gyp) will
automatically use node-waf to compile (seeing the wscript file),
but newer versions of npm (that do bundle node-gyp) will use node-gyp
to compiled because it sees the binding.gyp file.
  • Loading branch information...
1 parent 37566c3 commit db95d1c6bda213a6e1daef6e5c51ebc9a9826c8a @TooTallNate TooTallNate committed with defunctzombie Mar 30, 2012
Showing with 1 addition and 3 deletions.
  1. +1 −3 package.json
View
4 package.json
@@ -4,9 +4,7 @@
, "description" : "libxml bindings for v8 javascript engine"
, "version" : "0.5.4"
, "scripts" :
- { "install" : "node-waf configure build"
- , "preuninstall" : "node-waf clean"
- , "test" : "node --expose_gc ./node_modules/nodeunit/bin/nodeunit test"
+ { "test" : "node --expose_gc ./node_modules/nodeunit/bin/nodeunit test"
}
, "repository" :
{ "type" : "git"

0 comments on commit db95d1c

Please sign in to comment.