Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

drop 1.8 support and add 2.0

As MRI 1.8 is EOL, I think it is okay to drop 1.8 support.
  • Loading branch information...
commit d92dea46954b388ec13bc53c6e4f9894f25863c4 1 parent 2fffda3
@Gibheer Gibheer authored
Showing with 3 additions and 14 deletions.
  1. +3 −8 .travis.yml
  2. +0 −5 lib/zero.rb
  3. +0 −1  zero.gemspec
View
11 .travis.yml
@@ -1,15 +1,10 @@
bundler_args: --without development
language: ruby
rvm:
+ - 2.0.0
+ - jruby-20mode
+ - rbx-20mode
- 1.9.3
- - jruby-18mode
- jruby-19mode
- - rbx-18mode
- rbx-19mode
- - 1.8.7
script: thor spec
-matrix:
- allow_failures:
- - rvm: 1.8.7
- - rvm: rbx-18mode
- - rvm: jruby-18mode
View
5 lib/zero.rb
@@ -1,8 +1,3 @@
-# Only add fixes, if needed to avoid an unnecessary installed gem
-if RUBY_VERSION <= '1.9'
- require 'zero_fix18'
-end
-
module Zero
require 'zero/controller'
require 'zero/router'
View
1  zero.gemspec
@@ -20,5 +20,4 @@ Gem::Specification.new do |s|
s.rubygems_version = '1.8.24'
s.add_dependency('tilt')
- s.add_dependency('zero-fix18') if RUBY_VERSION <= '1.9'
end
Please sign in to comment.
Something went wrong with that request. Please try again.