Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Don't run Travis builds with Node v12 #1237

Closed
wincent opened this issue Apr 24, 2019 · 1 comment

Comments

Projects
None yet
1 participant
@wincent
Copy link
Member

commented Apr 24, 2019

Travis builds blow up because node-sass is not compatible with the just-released Node v12.

@wincent wincent added the chore label Apr 24, 2019

wincent added a commit that referenced this issue Apr 24, 2019

chore: make Travis use Node v11
Because node-sass is not compatible with the just-released v12, and is
causing all CI runs to blow up; example:

https://travis-ci.org/liferay/alloy-editor/builds/523839150

Closes: #1237

wincent added a commit that referenced this issue Apr 24, 2019

chore: make Travis use Node v11 (1.x) (#1237)
We needed to force the use of v11 on the master branch (see #1238)
because v12 was causing CI builds to blow up. This is not a problem on
the 1.x branch because we were still using v8. But we should use the
same version on both branches for consistency.

Related: #1237
@wincent

This comment has been minimized.

Copy link
Member Author

commented Apr 24, 2019

For reference, the upstream node-sass issue is: sass/node-sass#2632

@julien julien closed this in #1238 Apr 24, 2019

julien added a commit that referenced this issue Apr 24, 2019

Merge pull request #1238 from liferay/wincent/no-node-12
chore: make Travis use Node v11 (#1237)

wincent added a commit that referenced this issue Apr 24, 2019

chore: remove package-lock.json (#1237)
I just noticed that we have both a package-lock.json and a yarn.lock on
this branch.

- yarn.lock was added in 176cfd4 (Jan 2017) and only updated once, in
  c59af29 (also in Jan 2017).
- package-lock.json was added in e636edf (Oct 2017) and updated on a
  number of occasions, the latest being in 2cb99ed (April 2019).

Let's standardize on Yarn, to match what we're doing in the "master"
branch and in other projects.

wincent added a commit that referenced this issue Apr 24, 2019

chore: update gulp-sass (3.1.0 -> 4.0.2) (#1237)
Because we need to move to a newer node-sass in order to build
successfully with Node v11.

wincent added a commit that referenced this issue Apr 24, 2019

wincent added a commit that referenced this issue Apr 24, 2019

chore: remove package-lock.json (#1237)
I just noticed that we have both a package-lock.json and a yarn.lock on
this branch.

- yarn.lock was added in 176cfd4 (Jan 2017) and only updated once, in
  c59af29 (also in Jan 2017).
- package-lock.json was added in e636edf (Oct 2017) and updated on a
  number of occasions, the latest being in 2cb99ed (April 2019).

Let's standardize on Yarn, to match what we're doing in the "master"
branch and in other projects.

In order to get a working build I had to trash the yarn.lock and
regenerate it.

wincent added a commit that referenced this issue Apr 24, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.