Permalink
Browse files

2.10.0-{M7->RC1}

  • Loading branch information...
1 parent 229348d commit b97cecfbee550d93e2b877e9f3bc9cc4db7c6799 @nafg nafg committed Oct 24, 2012
View
@@ -12,8 +12,9 @@ startYear in ThisBuild := Some(2006)
organizationName in ThisBuild := "WorldWide Conferencing, LLC"
-crossScalaVersions in ThisBuild := Seq("2.10.0-M7", "2.9.2", "2.9.1-1", "2.9.1")
+crossScalaVersions in ThisBuild := Seq("2.10.0-RC1", "2.9.2", "2.9.1-1", "2.9.1")
+scalaBinaryVersion <<= scalaVersion
libraryDependencies in ThisBuild <++= scalaVersion {sv => Seq(specs2(sv), scalacheck) }
@@ -103,7 +103,9 @@ trait ManyToMany extends BaseKeyedMapper {
removedJoin // well, noLongerRemovedJoin...
case None =>
val newJoin = joinMeta.create
- thisField.actualField(newJoin).asInstanceOf[MappedForeignKey[K,O,T]] apply ManyToMany.this.primaryKeyField.is.asInstanceOf[K]
+ thisField.actualField(newJoin) match {
+ case mfk: MappedForeignKey[K,O,T] => mfk.set(primaryKeyField.is.asInstanceOf[K])
+ }
otherFK(newJoin)(_.apply(e))
newJoin
}
View
@@ -93,7 +93,7 @@ object BuildDef extends Build {
libraryDependencies <++= scalaVersion { sv =>
Seq(commons_fileupload, servlet_api, specs2(sv).copy(configurations = Some("provided")), jetty6, jwebunit)
},
- libraryDependencies <++= scalaVersion { case "2.10.0-M7" => scalaactors::Nil case _ => Nil },
+ libraryDependencies <++= scalaVersion { case s if s startsWith "2.10" => scalaactors(s)::Nil case _ => Nil },
initialize in Test <<= (sourceDirectory in Test) { src =>
System.setProperty("net.liftweb.webapptest.src.test.webapp", (src / "webapp").absString)
})
@@ -48,7 +48,7 @@ object Dependencies {
lazy val scalaz_core: ModuleMap = sv => scalazGroup(sv) % "scalaz-core" % scalazVersion(sv) cross CVMappingAll
lazy val slf4j_api = "org.slf4j" % "slf4j-api" % slf4jVersion
lazy val squeryl = "org.squeryl" % "squeryl" % "0.9.5-1" cross crossMapped("2.9.1-1" -> "2.9.1", "2.8.2" -> "2.8.1")
- @deprecated lazy val scalaactors= "org.scala-lang" % "scala-actors" % "2.10.0-M7"
+ @deprecated lazy val scalaactors= {v: String => "org.scala-lang" % "scala-actors" % v }
// Aliases
lazy val mongo_driver = mongo_java_driver
@@ -81,6 +81,6 @@ object Dependencies {
lazy val jwebunit = "net.sourceforge.jwebunit" % "jwebunit-htmlunit-plugin" % "2.5" % "test"
lazy val mockito_all = "org.mockito" % "mockito-all" % "1.9.0" % "test"
lazy val scalacheck = "org.scalacheck" %% "scalacheck" % "1.10.0" % "test" cross CrossVersion.full
- lazy val specs2: ModuleMap = "org.specs2" % "specs2" % defaultOrMapped("1.12.1","2.10.0-M7"->"1.12.1.1")(_) cross CrossVersion.full
+ lazy val specs2: ModuleMap = "org.specs2" % "specs2" % defaultOrMapped("1.12.1","2.10.0-RC1"->"1.12.2")(_) cross CrossVersion.full
}
View
@@ -1,2 +1,2 @@
# Deprecate using build.properties, use -Dsbt.version=... in launcher arg instead
-sbt.version=0.12.0-RC2
+sbt.version=0.12.1

0 comments on commit b97cecf

Please sign in to comment.