Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Loading…

Deprecate JSONParser #1310

Closed
wants to merge 1 commit into from

1 participant

@fmpwizard
Owner

As discussed here
https://groups.google.com/forum/?fromgroups#!topic/liftweb/1eEQjR02Lf0
We'll deprecate JSONParser in favor of using lift-json

@fmpwizard fmpwizard was assigned
@fmpwizard
Owner

just to keep track of this, I'll be doing rebase to master of pull requests this coming weekend

@fmpwizard fmpwizard closed this in 4b42594
@fmpwizard fmpwizard referenced this pull request from a commit
@fmpwizard fmpwizard Fixed #1310 - Deprecate JSONParser 18fad7f
@fmpwizard fmpwizard deleted the branch
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Commits on Dec 19, 2012
  1. @fmpwizard
This page is out of date. Refresh to see the latest.
Showing with 1 addition and 0 deletions.
  1. +1 −0  core/util/src/main/scala/net/liftweb/util/JSONParser.scala
View
1  core/util/src/main/scala/net/liftweb/util/JSONParser.scala
@@ -19,6 +19,7 @@ package util
import scala.util.parsing.combinator.{Parsers, ImplicitConversions}
import common._
+@deprecated("Use lift-json instead", "2.5")
object JSONParser extends SafeSeqParser with ImplicitConversions {
implicit def strToInput(in: String): Input = new scala.util.parsing.input.CharArrayReader(in.toCharArray)
type Elem = Char
Something went wrong with that request. Please try again.