Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP

Dependency error #1

Closed
d6y opened this Issue · 3 comments

3 participants

Richard Dallaway Diego Medina Peter Petersson
Richard Dallaway
Owner

The 2.5-M3 ZIP (and presumably TAR) will report...

module not found: net.liftmodules#lift-jquery-module_2.9.1;2.5-M3-1.0

...as the JQuery module was bumped to 2.0.

I'll attach a candidate fix to this issue in a few minutes.

Richard Dallaway
Owner

At the time of writing it appears GitHub is having an issue whereby changes are not automatically appearing here. There's a branch called d6y_issue1_jquery_ver that contains the following:

lift_25_sbt (d6y_issue1_jquery_ver)$ git diff master -U1
diff --git a/scala_29/lift_basic/build.sbt b/scala_29/lift_basic/build.sbt
index 013ccc1..0419d94 100644
--- a/scala_29/lift_basic/build.sbt
+++ b/scala_29/lift_basic/build.sbt
@@ -21,3 +21,3 @@ libraryDependencies ++= {
     "net.liftweb"       %% "lift-mapper"        % liftVersion        % "compile",
-    "net.liftmodules"   %% "lift-jquery-module" % (liftVersion + "-1.0"),
+    "net.liftmodules"   %% "lift-jquery-module" % (liftVersion + "-2.0"),
     "org.eclipse.jetty" % "jetty-webapp"        % "8.1.7.v20120910"  % "container,test",
diff --git a/scala_29/lift_blank/build.sbt b/scala_29/lift_blank/build.sbt
index 8a3e7d7..3ff58f4 100644
--- a/scala_29/lift_blank/build.sbt
+++ b/scala_29/lift_blank/build.sbt
@@ -20,3 +20,3 @@ libraryDependencies ++= {
     "net.liftweb"       %% "lift-webkit"        % liftVersion        % "compile",
-    "net.liftmodules"   %% "lift-jquery-module" % (liftVersion + "-1.0"),
+    "net.liftmodules"   %% "lift-jquery-module" % (liftVersion + "-2.0"),
     "org.eclipse.jetty" % "jetty-webapp"        % "8.1.7.v20120910"  % "container,test",
diff --git a/scala_29/lift_mvc/build.sbt b/scala_29/lift_mvc/build.sbt
index 013ccc1..0419d94 100644
--- a/scala_29/lift_mvc/build.sbt
+++ b/scala_29/lift_mvc/build.sbt
@@ -21,3 +21,3 @@ libraryDependencies ++= {
     "net.liftweb"       %% "lift-mapper"        % liftVersion        % "compile",
-    "net.liftmodules"   %% "lift-jquery-module" % (liftVersion + "-1.0"),
+    "net.liftmodules"   %% "lift-jquery-module" % (liftVersion + "-2.0"),
     "org.eclipse.jetty" % "jetty-webapp"        % "8.1.7.v20120910"  % "container,test",
Diego Medina
Owner

Thanks for reporting it and the fix, I just pushed the fix

[master c62bc97] * fixed #1 - thanks @d6y for the fix and reporting it!
 3 files changed, 3 insertions(+), 3 deletions(-)
sysadmins-MacBook-Pro-8:lift_basic diego.medina$ git push origin master
Counting objects: 15, done.
Delta compression using up to 8 threads.
Compressing objects: 100% (8/8), done.
Writing objects: 100% (8/8), 726 bytes, done.
Total 8 (delta 6), reused 0 (delta 0)
To git@github.com:lift/lift_25_sbt.git
   ff9f855..c62bc97  master -> master
Peter Petersson
Collaborator
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.