blank MVC template for Lift 2.4 and Scala 2.9.x, and configured for html5 parsing instead of default xhtml
Pull request Compare This branch is even with liftstack-build:master.
Fetching latest commit…
Cannot retrieve the latest commit at this time.
Permalink
Failed to load latest commit information.
project/project
src/main/g8
.gitignore
README.md
build.sbt

README.md

Giter8 template for Lift 2.4, Scala 2.9, blank, html5-ready

Quick Setup:

  1. Install Java SDK or OpenJDK.
  2. Install the Typesafe Stack (Scala, sbt, sbt-extras, giter8) *
  3. Install Lift and this template using giter8, run it with sbt and lifty:
g8 lift-stack/lift24-s29-blank
cd lift24-s29-blank (or whatever project name you choose from previous step)
sbt
lift jetty-run

Lift will be running on localhost:9000.

* Multiple install options. For \*nix users, if you choose to install Typesafe Stack via the Typesafe repo for your distro, a required dependency is OpenJDK. If you already have Oracle Java installed and want to run Typesafe and Lift on that instead of OpenJDK, your best bet is to use the last option on the download page - the Unversal Installer (just a zipped archive you put anywhere and add the bin directory to your PATH).

Requires:

  1. Java 6+ or OpenJDK installed
  2. Scala 2.9 installed *
  3. sbt 0.11+ installed *
  4. sbt launcher script installed and on your PATH *
  5. giter8 installed and on your PATH *

* #2-#5 can be easily done by installing the Typesafe Stack

Installs:

  1. lifty sbt plugin to ~/.sbt/plugins
  2. this lift project template in the current directory