Permalink
Browse files

Fix for issue #20 - added overridable resources definitions for plugin.

  • Loading branch information...
1 parent 55c8df5 commit f643ff4cabd3bc05f8939b50882d75c089a2e564 @bluesliverx bluesliverx committed Jan 8, 2012
Showing with 25 additions and 0 deletions.
  1. +14 −0 .gitignore
  2. +11 −0 grails-app/conf/JqueryValidationUiResources.groovy
View
@@ -0,0 +1,14 @@
+*.iws
+*Db.properties
+*Db.script
+.settings
+eclipse
+stacktrace.log
+target
+target-eclipse
+/plugins
+/web-app/plugins
+/web-app/WEB-INF/classes
+.link_to_grails_plugins
+*.zip
+plugin.xml
@@ -0,0 +1,11 @@
+modules = {
+ // NOTE: jquery validation is also required, but support
+ // needs to be added to the jquery-validation plugin first.
+ 'jquery-validation-ui' {
+ dependsOn 'jquery'
+ resource id:"qtip", url:[plugin:'jqueryValidationUi', dir:'js/qTip', file:'jquery.qtip.pack.js']
+ resource id:"validation-methods", url:[plugin:'jqueryValidationUi', dir:'js/jquery-validation-ui', file:'grails-validation-methods.js']
+
+ resource id:"qtip-theme", url:[plugin:'jqueryValidationUi', dir:'css/qTip', file:'jquery.qtip.css']
+ }
+}

0 comments on commit f643ff4

Please sign in to comment.