mmf-blog vue2.0 (vue2, vue-router, vuex)
Switch branches/tags
Nothing to show
Clone or download
Latest commit f7cadc9 Oct 25, 2018
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
build up Oct 25, 2018
config up Aug 23, 2018
src up Oct 20, 2018
static v2版本 Dec 24, 2016
.babelrc up Aug 23, 2018
.editorconfig first update Aug 12, 2016
.eslintignore first update Aug 12, 2016
.eslintrc.json eslint Apr 26, 2018
.gitignore eslint Apr 26, 2018
.prettierrc update Apr 22, 2018
README.md Update README.md Jul 15, 2017
README_CN.md Update README_CN.md Jul 15, 2017
favicon.ico no message Mar 19, 2018
package.json up Oct 25, 2018
postcss.config.js browserslist Jul 27, 2017
yarn.lock up Oct 25, 2018

README.md

mmf-blog vuejs 2.0 v2 中文说明

demo: http://vue2.mmxiaowu.com

The main technical stack: vue2, vue2-router, vuex, webpack, babel, eslint


Other versions

react(spa): https://github.com/lincenying/mmf-blog-react-v2

vue2(spa): https://github.com/lincenying/mmf-blog-vue2

vue2(ssr): https://github.com/lincenying/mmf-blog-vue2-ssr

vue2(pwa ssr): https://github.com/lincenying/mmf-blog-vue2-pwa-ssr


First installation api server:

koa2: https://github.com/lincenying/mmf-blog-api-koa2-v2

express: https://github.com/lincenying/mmf-blog-api-v2

# Install dependencies
yarn  #or  npm install
# Note: do not install with CNPM dependency

# Product
npm run build

# Develop
npm run dev

Home Site http://localhost:8081

Login http://localhost:8081/backend

notice:

Because babelrc configuration

"presets": [
    ["env", {
        "targets": {
            "chrome": 52
        }
    }]
]

So, in the development environment, please use chrome52 + open, if you need other low browser version, please modify the root directory of the .Babelrc file

LICENSE

MIT