Skip to content
Permalink
Browse files

chore: Need to pin versions for volta in every package.json.

Failure to do this causes volta to potentially use different versions
of node and yarn dependening on what directory you're in.
  • Loading branch information
chriseppstein committed Dec 4, 2019
1 parent 15c4f26 commit 67541021c88161ffc3874535eb00652e8972a281
@@ -70,6 +70,6 @@
},
"volta": {
"node": "12.2.0",
"yarn": "1.17.3"
"yarn": "1.21.0"
}
}
@@ -53,5 +53,9 @@
"opticss": "^0.6.3",
"symlink-or-copy": "^1.2.0",
"walk-sync": "^2.0.0"
},
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -62,5 +62,9 @@
"debug": "^4.1.1",
"fs-extra": "^8.0.0",
"yargs": "^13.2.2"
},
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -37,5 +37,9 @@
"files": [
"configs",
"*.md"
]
],
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -52,5 +52,9 @@
"cosmiconfig": "^6.0.0",
"debug": "^4.1.1",
"lodash.merge": "^4.6.2"
},
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -61,5 +61,9 @@
"engines": {
"node": "6.* || 8.* || >= 10.*"
},
"engineStrict": true
"engineStrict": true,
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -78,5 +78,9 @@
"tests/dummy/lib/in-repo-engine",
"tests/dummy/lib/in-repo-lazy-engine"
]
},
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -70,5 +70,9 @@
"glob": "^7.1.2",
"global": "^4.3.2",
"object.values": "^1.0.4"
},
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -63,5 +63,9 @@
"minimatch": "^3.0.4",
"object.values": "^1.0.4",
"opticss": "^0.6.3"
},
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -38,6 +38,7 @@
"watch": "watch 'yarn run test' './src' --wait=3"
},
"volta": {
"node": "10.13.0"
"node": "10.13.0",
"yarn": "1.21.0"
}
}
@@ -34,5 +34,9 @@
"engines": {
"node": "6.* || 8.* || >= 10.*"
},
"private": true
"private": true,
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -37,5 +37,9 @@
},
"devDependencies": {
"@css-blocks/code-style": "^0.24.0"
},
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -42,5 +42,9 @@
"engines": {
"node": "6.* || 8.* || >= 10.*"
},
"engineStrict": true
"engineStrict": true,
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -40,5 +40,9 @@
},
"devDependencies": {
"vscode": "^1.1.35"
},
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -69,5 +69,9 @@
"source-map": "^0.7.3",
"tapable": "^0.2.5",
"webpack-sources": "^1.0.1"
},
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}
@@ -106,5 +106,9 @@
"clean-css": "^4.1.11",
"obj-str": "^1.0.0"
},
"snyk": true
"snyk": true,
"volta": {
"node": "12.2.0",
"yarn": "1.21.0"
}
}

0 comments on commit 6754102

Please sign in to comment.
You can’t perform that action at this time.