Please stop the ~/.xsession-errors spam #369

Closed
leigh123linux opened this Issue Feb 19, 2012 · 17 comments

Comments

Projects
None yet
4 participants
Member

leigh123linux commented Feb 19, 2012

Please fix or suppress this warning as it's consuming many mega bytes per session

(cinnamon:1516): Clutter-WARNING **: clutter_actor_raise Actor 'panelBox' is not in the same container as actor 'MetaWindowActor'

(cinnamon:1516): Clutter-WARNING **: clutter_actor_raise Actor 'panelBox' is not in the same container as actor 'MetaWindowActor'

(cinnamon:1516): Clutter-WARNING **: clutter_actor_raise Actor 'panelBox' is not in the same container as actor 'MetaWindowActor'

(cinnamon:1516): Clutter-WARNING **: clutter_actor_raise Actor 'panelBox' is not in the same container as actor 'MetaWindowActor'

(cinnamon:1516): Clutter-WARNING **: clutter_actor_raise Actor 'panelBox' is not in the same container as actor 'MetaWindowActor'

(cinnamon:1516): Clutter-WARNING **: clutter_actor_raise Actor 'panelBox' is not in the same container as actor 'MetaWindowActor'

(cinnamon:1516): Clutter-WARNING **: clutter_actor_raise Actor 'panelBox' is not in the same container as actor 'MetaWindowActor'

(cinnamon:1516): Clutter-WARNING **: clutter_actor_raise Actor 'panelBox' is not in the same container as actor 'MetaWindowActor'

zenrox commented Feb 19, 2012

i have found this is a theme error i reset to the default theme and that "spam" stops

Contributor

alindt commented Feb 19, 2012

Do the warnings reappear if you switch back to the problem theme?

Member

leigh123linux commented Feb 19, 2012

The above output is generated using the default theme.

Contributor

alindt commented Feb 20, 2012

There must be something else instead (besides?) of the theme that's causing them because these two reports contradict themselves and I don't get the warnings with any of the themes.

zenrox commented Feb 20, 2012

i get them with some themes but as soon as i got to the stock theme it works just fine

Contributor

alindt commented Feb 20, 2012

I'm not disputing the fact that you get the warnings, I'm just saying that simply having a certain theme selected is not the main trigger. There must be something else you do while using your desktop that triggers the warnings, like alt-tabbing through windows, hovering over some applet, opening clicking on the menu button, and so on. I would suggest keeping open a small terminal window in a corner, set always on top and running a tail -f ~/.xsession-errors in it. That way you could see the warnings immediately and then correlate them with what you were doing at that moment.

From what I can see, the only explicit call to 'clutter_actor_raise' is:

  • src/st/st-widget.c: clutter_actor_raise (tooltip, NULL);

...but no tooltip popping up is triggering warnings for me.

As for "panelBox", it shows up in js/ui/layout.js and js/ui/main.js so the warnings may be related to something you do with/on the panels.

zenrox commented Feb 20, 2012

i do keep one running and its scrolling this error as soon as i switch to a theme thats not scrolling this error it stops scrolling imeadly and i personality think its how the theme is trying to display an image on the dock extention or some other extention with a tooltip or maby an applet who knows this seems like an intermintent issue gona be hard to pin it down none the less

Member

leigh123linux commented Feb 20, 2012

The trigger here to generate the error seems to be caused by clicking on the window-list tabs.

Contributor

alindt commented Feb 20, 2012

What applets/extesions and icons in the dock are running when it happens? Maybe an animated icon. Try to kill them all one at a time and see if you stumble upon THE one.

Contributor

alindt commented Feb 20, 2012

I'm clicking on the window-list apps like crazy while changing themes, but nothing come up. Who would've thought NOT getting errors would be so frustrating? :)

Contributor

alindt commented Feb 20, 2012

Nah, thanks, I haven't touched a RH-based distro error in 12 years and I'm not going to start revisiting them now. I'll stick to Debian flavoured ones, they're... cinnamonier :)

Member

leigh123linux commented Feb 20, 2012

Hopefully cinnamon will be in the fedora repo soon, I've got muffin in already.

https://bugzilla.redhat.com/show_bug.cgi?id=771252

Member

leigh123linux commented Feb 20, 2012

What package versions are you running?

[leigh@main_pc ~]$ rpm -q gtk3 clutter gjs muffin cinnamon |sort
cinnamon-1.3.0-2.fc16.x86_64
clutter-1.8.4-1.fc16.x86_64
gjs-1.30.1-1.fc16.x86_64
gtk3-3.2.3-1.fc16.x86_64
muffin-1.0.1-1.fc16.x86_64
[leigh@main_pc ~]$

Contributor

alindt commented Feb 20, 2012

Package: cinnamon Version: 1.3.0
Package: libclutter-1.0-0 Version: 1.8.0-1~svn1
Package: gjs Version: 1.30.0-0ubuntu1
Package: libgtk-3-0 Version: 3.2.0-0ubuntu6
Package: muffin Version: 1.0.1

glebihan added a commit that referenced this issue Feb 20, 2012

Member

glebihan commented Feb 20, 2012

This should be fixed now. Can you confirm ?

Member

leigh123linux commented Feb 20, 2012

I can confirm that your fix works.

thank you.

@glebihan glebihan closed this Feb 20, 2012

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment