Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

MDM login screen disappears on boot/reboot and has to be restarted #3

Closed
KirkM opened this issue May 23, 2012 · 10 comments

Comments

Projects
None yet
4 participants
@KirkM
Copy link

commented May 23, 2012

I'm seeing a problem with the login screen appearing for a second and then going to a blank screen during a normal boot/reboot. This happened every boot/reboot after the first set of updates for Maya RC but after the last set of updates I'm getting this on a random but still frequent basis. I end up having to Ctrl+Alt+F1 to a prompt, login and then typing...

sudo service mdm restart

...in order to get back to the login screen. In short, MDM keeps crashing(?) on me during a boot or reboot and I have to restart it. Logging out and logging back in works fine. I haven't found anything in the logs yet but I'm still looking. Here's my system specs:

Intel Core2 Quad, 8.0 GB DDR2, 1.0 TB HDD, Nvidia GT 430 w/1.0 GB DDR3 (running Nvida 295 driver)

Never had a problem with LightDM or GDM in the past. Not sure if this is a kernel problem or just a matter of timing. If there's a specific log I need to look at, please let me know. I'll post any needed log entires here.

@KirkM

This comment has been minimized.

Copy link
Author

commented May 24, 2012

After further research it appears to be a problem with the current Nvidia driver (295.40) which apparently has more bugs than usual which have been causing power and performance regressions for many users and this is the driver version that the "Additional Drivers" app installs by default (the "Recommended" driver).

Without getting into too much detail, the solution that worked for me is to install the "(post-release updates) (version current-updates)" driver instead (295.49). So far, this has solved the problem with MDM disappearing on boot/reboot and dropped my overall memory usage by approximately 50 MB.

@KirkM

This comment has been minimized.

Copy link
Author

commented May 25, 2012

Update:

The problem as stated in my first comment has returned. I see from the forums that I'm not the only one that is seeing this either. I still don't know whether this is a problem with MDM, the Nvidia drivers or the kernel itself. i do know that this problem didn't occur until the update to MDM came in two days ago.

@jordan-s

This comment has been minimized.

Copy link

commented May 28, 2012

Running Linux Mint 13 Cinnamon or MATE with the proprietary Nvidia drivers installed, the MDM login screen (1.0.4) will randomly (more often than not) display for 1 or 2 seconds and then disappear leaving a blank screen. I either need to CNTL-ALT-DEL to return to the grub menu or CNTL-ALT-F1 to bring me to a command prompt where I can restart the MDM service. I tried various other login managers with no issues including LXDM, GDM and LightDM.

@clefebvre

This comment has been minimized.

Copy link
Member

commented Aug 30, 2012

Don't hesitate to link to the forums post.

This is troubling but I've not enough information here to identify the cause of the problem.

@KirkM

This comment has been minimized.

Copy link
Author

commented Aug 30, 2012

Clem - You can start at this forum post and continue from there:

http://forums.linuxmint.com/viewtopic.php?f=143&t=102278&start=80#p583160

The problem does affect others as well but the kink in the whole thing is the "disappearing" MDM does not leave anything in the logs that anyone has found. It boils down to this. If the proprietary Nvidia driver is not installed, MDM is fine. Nvidia driver is installed, then MDM disappears on boot/reboot after 1 to 2 seconds after it first appears.

Note: This problem didn't exist until after an update was done sometime on 05-21-2012 (going by the Git dating system).

@jordan-s

This comment has been minimized.

Copy link

commented Aug 30, 2012

One more point: In my experience, this issue has occurred with any version of Nvidia driver I have installed, and I have tried several including the latest 304.xx.

I can't find any log files as well.

@runfalk

This comment has been minimized.

Copy link

commented Jul 26, 2013

I can confirm this as well with MDM 1.2.5. I run it on a laptop with Intel GMA 4000 graphics. It happens on a irregular basis.

I've since removed xserver-xorg-video-radeon, xserver-xorg-video-nouveau and nvidia-common packages. I will update this issue if it worked.

@runfalk

This comment has been minimized.

Copy link

commented Jul 27, 2013

The issue persists even though I have removed both nouveau and radeon drivers.

@runfalk

This comment has been minimized.

Copy link

commented Aug 21, 2013

I've found some clues. This problem only seem to occur when using GDM themes. I since switching to HTML themes I haven't had any issues. I've had the same problem on two separate LM15 installations.

The log pasted below is from a computer using AMD's catalyst drivers.

X.Org X Server 1.13.3
Release Date: 2013-03-07
X Protocol Version 11, Revision 0
Build Operating System: Linux 3.2.0-37-generic x86_64 Ubuntu
Current Operating System: Linux Balthazar 3.8.0-19-generic #29-Ubuntu SMP Wed Apr 17 18:16:28 UTC 2013 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.8.0-19-generic root=UUID=f76faf9f-3aa4-4749-97d2-4feafa5e09ba ro quiet splash vt.handoff=7
Build Date: 17 April 2013  10:43:13PM
xorg-server 2:1.13.3-0ubuntu6 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.28.2
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
    (++) from command line, (!!) notice, (II) informational,
    (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Wed Aug 21 18:50:35 2013
(==) Using config file: "/etc/X11/xorg.conf"
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
Initializing built-in extension Generic Event Extension
Initializing built-in extension SHAPE
Initializing built-in extension MIT-SHM
Initializing built-in extension XInputExtension
Initializing built-in extension XTEST
Initializing built-in extension BIG-REQUESTS
Initializing built-in extension SYNC
Initializing built-in extension XKEYBOARD
Initializing built-in extension XC-MISC
Initializing built-in extension SECURITY
Initializing built-in extension XINERAMA
Initializing built-in extension XFIXES
Initializing built-in extension RENDER
Initializing built-in extension RANDR
Initializing built-in extension COMPOSITE
Initializing built-in extension DAMAGE
Initializing built-in extension MIT-SCREEN-SAVER
Initializing built-in extension DOUBLE-BUFFER
Initializing built-in extension RECORD
Initializing built-in extension DPMS
Initializing built-in extension X-Resource
Initializing built-in extension XVideo
Initializing built-in extension XVideo-MotionCompensation
Initializing built-in extension SELinux
Initializing built-in extension XFree86-VidModeExtension
Initializing built-in extension XFree86-DGA
Initializing built-in extension XFree86-DRI
Initializing built-in extension DRI2
Loading extension GLX
(WW) fglrx: No matching Device section for instance (BusID PCI:0@7:0:1) found
Loading extension ATIFGLRXDRI
Loading extension FGLRXEXTENSION
Loading extension GLESX
Loading extension AMDXVOPL
Loading extension AMDXVBA
(EE) 
(EE) Backtrace:
(EE) 0: /usr/bin/X (xorg_backtrace+0x36) [0x7fb0d100c476]
(EE) 1: /usr/bin/X (0x7fb0d0e5c000+0x1b42b9) [0x7fb0d10102b9]
(EE) 2: /lib/x86_64-linux-gnu/libpthread.so.0 (0x7fb0cff5f000+0xfbd0) [0x7fb0cff6ebd0]
(EE) 3: /usr/lib/x86_64-linux-gnu/libpciaccess.so.0 (0x7fb0d017c000+0x4c3e) [0x7fb0d0180c3e]
(EE) 4: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so (amd_xs113_int10_x_inb+0x46) [0x7fb0cd3950a6]
(EE) 5: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so (0x7fb0ccaf2000+0x89bd85) [0x7fb0cd38dd85]
(EE) 6: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so (X86EMU_exec+0xa5) [0x7fb0cd3814d5]
(EE) 7: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so (amd_xs113_int10_xf86ExecX86int10+0x46) [0x7fb0cd396206]
(EE) 8: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so (xf86ExecX86int10+0xd) [0x7fb0cce78ddd]
(EE) 9: /usr/lib/xorg/modules/libvbe.so (VBESetVBEMode+0x9d) [0x7fb0cc4d84ed]
(EE) 10: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so (0x7fb0ccaf2000+0x3ba463) [0x7fb0cceac463]
(EE) 11: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so (atiddxVBESetConsoleMode+0x44) [0x7fb0cceac2b4]
(EE) 12: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so (xdl_xs113_atiddxFreeScreen+0x730) [0x7fb0ccfd4030]
(EE) 13: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so (xdl_xs113_atiddxCloseScreen+0x321) [0x7fb0ccfd3661]
(EE) 14: /usr/lib/x86_64-linux-gnu/xorg/extra-modules/modules/drivers/fglrx_drv.so (0x7fb0ccaf2000+0x9037c6) [0x7fb0cd3f57c6]
(EE) 15: /usr/bin/X (0x7fb0d0e5c000+0xea338) [0x7fb0d0f46338]
(EE) 16: /usr/bin/X (0x7fb0d0e5c000+0x135fb4) [0x7fb0d0f91fb4]
(EE) 17: /usr/bin/X (0x7fb0d0e5c000+0x47687) [0x7fb0d0ea3687]
(EE) 18: /lib/x86_64-linux-gnu/libc.so.6 (__libc_start_main+0xf5) [0x7fb0cebacea5]
(EE) 19: /usr/bin/X (0x7fb0d0e5c000+0x478c1) [0x7fb0d0ea38c1]
(EE) 
(EE) Segmentation fault at address 0x0

Fatal server error:
Caught signal 11 (Segmentation fault). Server aborting

(EE) 
Please consult the The X.Org Foundation support 
     at http://wiki.x.org
 for help. 
(EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
(EE) 
Server terminated with error (1). Closing log file.
@clefebvre

This comment has been minimized.

Copy link
Member

commented Oct 7, 2013

@clefebvre clefebvre closed this Mar 12, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.