Fail the build if the coverage falls below a pre configured value
Clone or download
Fetching latest commit…
Cannot retrieve the latest commit at this time.

README.md

karma-threshold-reporter

Fail the build if the coverage falls below a pre configured value

Installation

The easiest way is to keep karma-threshold-reporter as a devDependency in your package.json.

{
  "devDependencies": {
    "karma": "~0.10",
    "karma-threshold-reporter": "~0.1.7"
  }
}

You can simple do it by:

npm install karma-threshold-reporter --save-dev

NPM Stats

Configuration

// karma.conf.js or karma-e2e.conf.js
module.exports = function(config) {
  config.set({
  
    plugins: ['karma-threshold-reporter'],
  
    reporters: ['progress', 'coverage','threshold'],

    // the configure thresholds
    thresholdReporter: {
      statements: 90,
      branches: 60,
      functions: 85,
      lines: 90
    }
  });
};

You can pass list of reporters as a CLI argument too:

karma start --reporters coverage,threshold

For more information on Karma see the homepage.