Permalink
Browse files

Install non-bundle dependencies for eclipse PDE in install phase

otherwise, maven-dependency-plugin:analyze-only fails the build because
undeclared dependencies are found (presumably used by
maven-dependency-plugin that installs the dependencies)
  • Loading branch information...
ykazakov committed Jan 19, 2019
1 parent df4fb27 commit 4e59d8cdcdbafeb16da5d4a8b841235f8f04db94
Showing with 4 additions and 3 deletions.
  1. +4 −3 elk-protege/pom.xml
@@ -1,4 +1,5 @@
<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
<project xmlns="http://maven.apache.org/POM/4.0.0"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd">
<modelVersion>4.0.0</modelVersion>

@@ -178,8 +179,8 @@
<artifactId>maven-dependency-plugin</artifactId>
<executions>
<execution>
<id>include-non-bundle-dependencies</id>
<phase>package</phase>
<id>install-non-bundle-dependencies</id>
<phase>install</phase>
<goals>
<goal>unpack-dependencies</goal>
</goals>

0 comments on commit 4e59d8c

Please sign in to comment.