copy filter work wrong on binary files #98

Open
rkmax opened this Issue Oct 16, 2012 · 6 comments

Comments

Projects
None yet
5 participants

rkmax commented Oct 16, 2012

when i try to copy file like images (ico, png) always the size grows

AssetFile

$: << 'lib'

require 'rake-pipeline'


output  'src/images'
input 'public/images' do
  match '*.png' do
    copy
  end
end

Command used

$ rakep

Enviroment

Ruby 1.9.3p194 (2012-04-20) [i386-mingw32]
Windows 8 x64 bits

gem rake-pipeline 0.7.0
gem rake-pipeline-web-filters 0.7.0

I think this might be fixed in #112, but I've only tested it on my Mac. Would you be able to try it on your Windows machine and see if it works? Thanks!

Contributor

wagenet commented Nov 13, 2012

@rkmax Any chance to look at this?

eduplus commented Jan 24, 2013

I am getting this still, this is a showstopper. Any updates on this?

The same here...

Images get corrupted with both binary concat and copy filters:

BINARY CONCAT

ConcatFilter = Rake::Pipeline::ConcatFilter
ConcatFilter.processes_binary_files()
match "static/*/" do
filter ConcatFilter do |input|
input.sub(/static//, '')
end
end

COPY

match 'static/*/' do
copy
end

ENVIRONMENT

Ruby 1.9.3p194 (2012-04-20) [i386-mingw32]
Windows 8 x64 bits

gem rake-pipeline 0.8.0
gem rake-pipeline-web-filters 0.7.0

Has anyone found a solution for this?

I've just updated my pull request on this (#112) to the solution I've been using for awhile. It successfully copies images & fonts for me. Can anyone else try this out and see if it works for them?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment