New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Function imagepng() is seen as requiring PHP 7.1.9 #241

Closed
TheFirsh opened this Issue Feb 1, 2018 · 8 comments

Comments

Projects
None yet
3 participants
@TheFirsh
Copy link

TheFirsh commented Feb 1, 2018

In the Functions Analysis section, the right column "EXT min/Max PHP min/Max" (why is there a max?) shows 7.1.9, like this:

imagepng 1 gd 4.0.0 7.1.9

I'm pretty sure that it doesn't require 7.1.9 nor did it get deprecated in 7.2.

@remicollet

This comment has been minimized.

Copy link
Contributor

remicollet commented Feb 1, 2018

Probably because 7.2 is not yet supported

@TheFirsh

This comment has been minimized.

Copy link

TheFirsh commented Feb 1, 2018

What's the connection to that particular function? I ran this on the entire project and only that one thing popped out.

@remicollet

This comment has been minimized.

Copy link
Contributor

remicollet commented Feb 1, 2018

Indeed something looks strange

   {
        "ext_name_fk": 18,
        "name": "imagepng",
        "ext_min": "4.0.0",
        "ext_max": "",
        "php_min": "4.0.0",
        "php_max": "",
        "parameters": "4.0.0, 4.0.0, 7.1.9, 7.1.9",
        "php_excludes": ""
    },

As from documentation

  • 5.1.3 | Added the filters parameter.
  • 5.1.2 | Added the quality parameter.
@remicollet

This comment has been minimized.

Copy link
Contributor

remicollet commented Feb 1, 2018

Easy fix

-        "parameters": "4.0.0, 4.0.0, 7.1.9, 7.1.9",
+        "parameters": "4.0.0, 4.0.0, 5.1.2, 5.1.3",

@TheFirsh it didn't report any max version

Extensions Analysis

    Extension Matches REF  EXT min/Max PHP min/Max PHP all 
    Core              Core             4.0.0               
    gd                gd   4.0.0       7.1.9               
    Total [2]                          7.1.9               

But a bad minimal version.

@TheFirsh

This comment has been minimized.

Copy link

TheFirsh commented Feb 1, 2018

Thanks. I don't know how it would look like if it were showing a max version, never encountered that. Glad to know it seems like a bug and not my oversight. But how do I apply the fix and where? I installed the phar version using this line: sudo mv phpcompatinfo-5.0.11.phar /usr/local/bin/phpcompatinfo

@llaville

This comment has been minimized.

Copy link
Owner

llaville commented Feb 1, 2018

The fix will be include in next release of php-compatinfo-db (1.29.0) that support all elements versions.
Will be soon, because PHP 7.1.14 has just been released.

Later I'll publish a new php-compatinfo version 5.0.12 that will include compatinfo-db 1.29

BTW, current phar version of compatinfo 5.0.11 include DB version 1.26

@llaville

This comment has been minimized.

Copy link
Owner

llaville commented Feb 1, 2018

FIX already avaliable (see llaville/php-compatinfo-db@7e5946e).

Packages releases will follow !

Thanks to @TheFirsh for reporting and @remicollet for analysis :)

@llaville

This comment has been minimized.

Copy link
Owner

llaville commented Feb 1, 2018

Versions have just been released !

@llaville llaville closed this Feb 1, 2018

@llaville llaville added the bug label Feb 1, 2018

@llaville llaville self-assigned this Feb 1, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment