Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Allow LLDB to support Python 3.5 #24835

Closed
llvmbot opened this issue Aug 14, 2015 · 0 comments
Closed

Allow LLDB to support Python 3.5 #24835

llvmbot opened this issue Aug 14, 2015 · 0 comments
Labels
bugzilla lldb

Comments

@llvmbot
Copy link
Collaborator

@llvmbot llvmbot commented Aug 14, 2015

Bugzilla Link 24461
Resolution FIXED
Resolved on Feb 16, 2016 16:26
Version unspecified
OS Windows NT
Reporter LLVM Bugzilla Contributor

Extended Description

In Bug 21920 a problem is described that makes Python very difficult to use on Windows. Python 3.5 on Windows is implemented in such a way as to be forward compatible with future versions of Visual Studio. As a result, we've decided that the best way forward is to allow LLDB to support Python 3.5. Since there are already potentially hundreds of thousands of lines of Python code written against 2.7, we will need to do this in such a way that LLDB supports both Python 2.7 and Python 3.5+.

The biggest difficulty and pain point arising from this will be the need for the test suite and all specific tests to be written using a subset of Python that will work in both 2.7 and 3.5.

In order to ensure this requirement is met, part of this task will involve setting up at least two build bots: one that runs tests using 2.7 and another that runs tests using 3.5.

@llvmbot llvmbot transferred this issue from llvm/llvm-bugzilla-archive Dec 10, 2021
This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
bugzilla lldb
Projects
None yet
Development

No branches or pull requests

1 participant