Permalink
Browse files

Add support for running tests against Python 3.3-3.5

  • Loading branch information...
1 parent 32ce544 commit 96ace147d1cee4d3f425aa85d517df2820f9e40b @pmdarrow pmdarrow committed Dec 2, 2015
Showing with 18 additions and 0 deletions.
  1. +1 −0 .gitignore
  2. +3 −0 .travis.yml
  3. +4 −0 setup.py
  4. +10 −0 tox.ini
View
@@ -12,3 +12,4 @@ dist/**
.vagrant
build/
.coverage
+.tox/
View
@@ -2,6 +2,9 @@ language: python
python:
- "2.6"
- "2.7"
+ - "3.3"
+ - "3.4"
+ - "3.5"
# command to install dependencies
install:
- sudo apt-get install -y libevent-dev
View
@@ -42,6 +42,10 @@ def run(self):
"Programming Language :: Python :: 2",
"Programming Language :: Python :: 2.6",
"Programming Language :: Python :: 2.7",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
"Intended Audience :: Developers",
"Intended Audience :: System Administrators",
],
View
@@ -0,0 +1,10 @@
+[tox]
+envlist = py26, py27, py33, py34, py35
+
+[testenv]
+deps =
+ mock
+ pyzmq
+ unittest2
+commands =
+ unit2 discover []

0 comments on commit 96ace14

Please sign in to comment.