Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

cmake: check for libnotiy version

we are requiring 0.7 so we should check against it
  • Loading branch information...
commit 0896d68b6306bfc23e31e535174ab01d8fb9b91e 1 parent 92b9587
@karolherbst karolherbst authored
Showing with 6 additions and 0 deletions.
  1. +3 −0  CMakeLists.txt
  2. +3 −0  cmake/modules/FindNotify.cmake
View
3  CMakeLists.txt
@@ -112,6 +112,9 @@ if(NOT BUILD_ONLY_CEF)
if(NOT WIN32)
find_package(Boost COMPONENTS date_time filesystem thread system REQUIRED)
find_package(Notify REQUIRED)
+ if(NOT HAVE_LIBNOTIFY_0_7)
+ message(FATAL_ERROR "libnotify >= 0.7 is required")
+ endif()
endif()
find_package(BZip2 ${REQUIRED_IF_OPTION})
View
3  cmake/modules/FindNotify.cmake
@@ -118,9 +118,12 @@ if(LIBNOTIFY_FOUND)
if(NOT LIBNOTIFY_FIND_QUIETLY)
if(LIBNOTIFY_VERSION_07)
+ set(HAVE_LIBNOTIFY_0_4 TRUE)
+ set(HAVE_LIBNOTIFY_0_7 TRUE)
message(STATUS "Found libnotify: '${LIBNOTIFY_LIBRARIES}' and header in '${LIBNOTIFY_INCLUDE_DIR}' version => 0.7")
endif(LIBNOTIFY_VERSION_07)
if(LIBNOTIFY_VERSION_04)
+ set(HAVE_LIBNOTIFY_0_4 TRUE)
message(STATUS "Found libnotify: '${LIBNOTIFY_LIBRARIES}' and header in '${LIBNOTIFY_INCLUDE_DIR}' version => 0.4")
endif(LIBNOTIFY_VERSION_04)
endif(NOT LIBNOTIFY_FIND_QUIETLY)
Please sign in to comment.
Something went wrong with that request. Please try again.