Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

2.0.1 support - which requires latest Riddle release.

  • Loading branch information...
commit b688c83ee743cb95799c930be6e9a95b91eeec88 1 parent 3b5dd7f
@pat pat authored
View
2  Gemfile
@@ -1,7 +1,7 @@
source 'http://rubygems.org'
gem 'activerecord', '>= 1.15.6', '< 3.0.0'
-gem 'riddle', '>= 1.2.2'
+gem 'riddle', '>= 1.3.0'
gem 'after_commit', '>= 1.0.7'
group :development do
View
4 lib/thinking_sphinx/auto_version.rb
@@ -5,8 +5,10 @@ def self.detect
case version
when '0.9.8', '0.9.9'
require "riddle/#{version}"
- when '1.10-beta', '1.10-id64-beta', '1.10-dev'
+ when /1.10/
require 'riddle/1.10'
+ when /2.0.1/
+ require 'riddle/2.0.1'
else
documentation_link = %Q{
For more information, read the documentation:
View
10 spec/thinking_sphinx/auto_version_spec.rb
@@ -30,7 +30,7 @@
ThinkingSphinx::AutoVersion.detect
end
- it "should require 1.10-beta if that is the detected version" do
+ it "should require 1.10-beta if using 1.10-beta compiled with id64 support" do
ThinkingSphinx::AutoVersion.should_receive(:require).
with('riddle/1.10')
@@ -38,6 +38,14 @@
ThinkingSphinx::AutoVersion.detect
end
+ it "should require 2.0.1 if using Sphinx 2.0.1 beta" do
+ ThinkingSphinx::AutoVersion.should_receive(:require).
+ with('riddle/2.0.1')
+
+ @config.stub!(:version => '2.0.1-beta')
+ ThinkingSphinx::AutoVersion.detect
+ end
+
it "should output a warning if the detected version is unsupported" do
STDERR.should_receive(:puts).with(/unsupported/i)
Please sign in to comment.
Something went wrong with that request. Please try again.