Fix node engine in package.json #128

Merged
merged 1 commit into from Apr 1, 2013

Conversation

Projects
None yet
3 participants
Contributor

dignifiedquire commented Apr 1, 2013

This is the correct specification of the node engine, otherwise it gets ignored by npm. Please also fix this in the 0.5.7 version so we can do installs depending on the node version.

@dignifiedquire dignifiedquire referenced this pull request in karma-runner/karma Apr 1, 2013

Closed

Logger issues. Again. #448

@@ -17,7 +17,9 @@
"bugs": {
"url": "http://github.com/nomiddlename/log4js-node/issues"
},
- "engines": [ "node >=0.10" ],
+ "engines": {
+ "node": ">=0.10"
@vojtajina

vojtajina Apr 1, 2013

you should set it to ~0.10

if node 0.12 brings an incompatible change that breaks log4js, this version won't work with node 0.12 anymore (but NPM will allow installing it) and therefore you will release a new patched version, where you define engine ~0.10 || ~0.12.

if you wanna allow unstable versions of node, you can do ~0.10 || ~0.11

nomiddlename pushed a commit that referenced this pull request Apr 1, 2013

@nomiddlename nomiddlename merged commit 0544342 into log4js-node:master Apr 1, 2013

1 check passed

default The Travis build passed
Details

@nomiddlename check my comment please

Can you please push 0.5.8 release to the npm (for people using node 0.8) and specify engine to ~0.8 ? I can send you pull request if it helps... (current 0.5.7 says it works with node 0.10, but it does not).

Can you also change the engine to ~0.10 or ~0.10 || ~0.11 and push a new release (0.6.1) to npm ? Currently log4js is breaking people to install Karma on 0.8 node, releasing 0.5.8 and 0.6.1 would solve this.

Thanks @nomiddlename - let me know if I can help you...

Collaborator

nomiddlename commented Apr 1, 2013

Will do. Thanks for the change. I've published 0.5.8 (with engines.node = "~0.6||~0.8") and 0.6.1 (with engines.node = "~0.10").

Awesome! Thanks for such a quick fix!

Collaborator

nomiddlename commented Apr 2, 2013

No worries. I was wondering why I was getting so many people trying to use log4js@0.6.0 with node 0.8, but I was too stupid to check the package.json. Sorry for causing so many problems.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment