select box won't stay open in IE9 in IE8 mode #194

Open
johnallan opened this Issue Jan 6, 2012 · 5 comments

Comments

Projects
None yet
5 participants
@johnallan

The example we have is a select box with a drop-shadow applied using PIE. Of course IE9 supports shadows itself but when it is in IE8 mode the select box will not stay open once you move your mouse into the drop-down area. In native IE8 it is fine. Have not tried this with other effects.

@steve-acet

This comment has been minimized.

Show comment
Hide comment
@steve-acet

steve-acet Feb 9, 2012

I have the same problem with IE8. I am just applying rounded corners to a select. When I click on it the select appears, but as soon as I move my mouse to select an option it vanishes.

I have the same problem with IE8. I am just applying rounded corners to a select. When I click on it the select appears, but as soon as I move my mouse to select an option it vanishes.

@lojjic

This comment has been minimized.

Show comment
Hide comment
@lojjic

lojjic Feb 18, 2013

Owner

Does setting -pie-track-hover:false help?

Owner

lojjic commented Feb 18, 2013

Does setting -pie-track-hover:false help?

@IberoMedia

This comment has been minimized.

Show comment
Hide comment
@IberoMedia

IberoMedia Jun 12, 2013

no, adding -pie-track-hover:false does not help.

If I use the latest pie 2.0 it is worst. The select won't even show options

Any other suggestions?

no, adding -pie-track-hover:false does not help.

If I use the latest pie 2.0 it is worst. The select won't even show options

Any other suggestions?

@lojjic

This comment has been minimized.

Show comment
Hide comment
@lojjic

lojjic Jun 16, 2013

Owner

Everyone: the original post said that it works fine in native IE8, and only fails in IE9 running in IE8 compatibility mode. Can you please verify for me that this is indeed the case?

If it's just a compatibility mode issue then I'm not too concerned about it, but if it happens in real IE8 then it's higher priority.

Owner

lojjic commented Jun 16, 2013

Everyone: the original post said that it works fine in native IE8, and only fails in IE9 running in IE8 compatibility mode. Can you please verify for me that this is indeed the case?

If it's just a compatibility mode issue then I'm not too concerned about it, but if it happens in real IE8 then it's higher priority.

@antonpegov

This comment has been minimized.

Show comment
Hide comment
@antonpegov

antonpegov May 10, 2017

It happens in real IE8.

It happens in real IE8.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment