Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Minimum PHP Version #1140

mwhitneysdsu opened this issue Jul 13, 2015 · 8 comments

Minimum PHP Version #1140

mwhitneysdsu opened this issue Jul 13, 2015 · 8 comments


Copy link

@mwhitneysdsu mwhitneysdsu commented Jul 13, 2015

#810 was the last time the minimum PHP Version for Bonfire was updated, a little over 2 years ago.

CI 3 bumps the minimum version up from 5.1.6 to 5.2.4, but both CI 2.2.2 and 3.0 (as well as Bonfire) work perfectly fine on newer versions of PHP.

The biggest issue I see with upgrading the minimum version is that some operating system releases targeted at server admins are still running 5.3 (for example, Ubuntu 12.04 LTS, which doesn't reach end of life for almost 2 years; but Ubuntu 14.04 LTS was released over a year ago with PHP 5.5).

The benefits of upgrading the minimum version to 5.4 would be:
traits, short array syntax, support for $this in closures, class member access on instantiation, etc., and 5.4 doesn't reach end of life for 2 more months (as opposed to 5.3, which hit end of life 10 months ago).

If no one has a problem with upgrading the minimum version to 5.4, I would expect it to go through alongside the removal of support for CI 2.x in the 1.0 release (so 0.7.x and 0.8.x would still support 5.3). I also don't intend to make/merge changes to the code base just for the sake of using the new features (like converting array declarations to short array syntax), at least in the short term.

I would probably expect an upgrade to 5.5 to come along a little more quickly than the upgrade from 5.3 to 5.4. From my cursory exploration of the shipped OS versions, many jumped from 5.3 to 5.5 anyway, or those which did not tend to be on a shorter release schedule.

Just to be clear, none of this means that you have to run the minimum version, just that you can't run an older version than the minimum. We would still upgrade Bonfire as needed to ensure it can run on newer versions, we just wouldn't add features in such a way that requires someone to use a newer version than the minimum.

Copy link

@lonnieezell lonnieezell commented Jul 13, 2015

I think that's a great idea, personally. I don't know how it will impact others, but there are a number of security performance improvements between those versions of PHP, also, that benefit everyone.

Unless you get a very vocal group here saying no, then I'd say go for it. :)

Copy link

@softwarespot softwarespot commented Jul 19, 2015

I agree, 5.4 is the way forward

Copy link

@ghost ghost commented Jul 28, 2015

Yes, 5.4 or greater

Copy link

@dasegn dasegn commented Jul 29, 2015

5.4 or greater is the option

Copy link

@samoir samoir commented Aug 5, 2015

Yes 5.4 or greater. We're using PHP 5.6 on 0.7.x and PHP 5.3 on 0.6.x instances.

Copy link
Contributor Author

@mwhitneysdsu mwhitneysdsu commented Aug 6, 2015

A few announcements have been posted.

I'm still interested in finding out what version of PHP everyone is using. Everything before 0.9 will continue to work with PHP 5.3, but I'm moving forward with 5.4 as the minimum supported PHP version in the develop branch (what I'm currently calling v0.9.0-dev).

Copy link

@markbratanov markbratanov commented Aug 10, 2015

Current PHP Version: 5.4.40

Copy link

@alexmocanu alexmocanu commented Aug 11, 2015

Current version: 5.4 with some hosts already switching to 5.5

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
7 participants
You can’t perform that action at this time.