Skip to content
Permalink
Browse files

Downgrade ts-loader package to preserve Node v6 compatibility

  • Loading branch information...
lovett committed May 24, 2019
1 parent a001805 commit c0c3ed17ad66d410385b94ab45330e8333c12690
Showing with 25 additions and 78 deletions.
  1. +5 −1 Makefile
  2. +19 −76 package-lock.json
  3. +1 −1 package.json
@@ -69,8 +69,12 @@ hooks: dummy
# from producing a warning. Non-zero exit here is not an indicator of
# badness.
#
# The ts-loader is omitted from output as a means of pinning the
# current version to retain compatibility with node v6. The current
# version of ts-loader has a dependency that does not work with node
# 6. See https://github.com/TypeStrong/ts-loader/issues/929
outdated: dummy
npm outdated || true
npm outdated | grep -v 'ts-loader' || true

setup: export NPM_CONFIG_PROGRESS = false
setup: export NODE_ENV=dev

Some generated files are not rendered by default. Learn more.

@@ -83,7 +83,7 @@
"stylelint-config-standard": "18.3.0",
"supertest": "4.0.2",
"terser-webpack-plugin": "1.3.0",
"ts-loader": "6.0.1",
"ts-loader": "5.4.5",
"ts-node": "8.1.0",
"tslint": "5.16.0",
"typescript": "3.4.5",

0 comments on commit c0c3ed1

Please sign in to comment.
You can’t perform that action at this time.