Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[util] build_docs.py should check if existing hugo is hugo-extended #757

Closed
asb opened this issue Nov 1, 2019 · 0 comments · Fixed by #968

Comments

@asb
Copy link
Member

@asb asb commented Nov 1, 2019

We require hugo-extended to build the docs for OpenTitan. Unfortunately, this still uses the hugo binary name. The logic added to build_docs.py will download hugo if it's not available. But the experience could be improved in the case that a hugo binary exists, but it's not hugo-extended.

build_docs.py should be updated to check hugo version output for the "extended" string, and to still download a copy of hugo if "extended" isn't found.

silvestrst added a commit to silvestrst/opentitan that referenced this issue Nov 13, 2019
build_docs.py uses hugo-extended to build the docs for OpenTitan, which
is stored as the binary named "hugo". When this binary is present the script
does not check whether the version is extended.

This change adds a hugo version check, which makes sure that the binary is
extended, and downloads the correct version if it is not.

Fixes lowRISC#757
Signed-off-by: Silvestrs Timofejevs <silvestrst@lowrisc.org>
silvestrst added a commit to silvestrst/opentitan that referenced this issue Nov 13, 2019
build_docs.py uses hugo-extended to build the docs for OpenTitan, which
is stored as the binary named "hugo". When this binary is present the script
does not check whether the version is extended.

This change adds a hugo version check, which makes sure that the binary is
extended, and downloads the correct version if it is not.

Fixes lowRISC#757
Signed-off-by: Silvestrs Timofejevs <silvestrst@lowrisc.org>
silvestrst added a commit to silvestrst/opentitan that referenced this issue Nov 13, 2019
build_docs.py uses hugo-extended to build the docs for OpenTitan, which
is stored as the binary named "hugo". When this binary is present the script
does not check whether the version is extended.

This change adds a hugo version check, which makes sure that the binary is
extended, and downloads the correct version if it is not.

Fixes lowRISC#757
Signed-off-by: Silvestrs Timofejevs <silvestrst@lowrisc.org>
@imphil imphil closed this in #968 Nov 13, 2019
imphil added a commit that referenced this issue Nov 13, 2019
build_docs.py uses hugo-extended to build the docs for OpenTitan, which
is stored as the binary named "hugo". When this binary is present the script
does not check whether the version is extended.

This change adds a hugo version check, which makes sure that the binary is
extended, and downloads the correct version if it is not.

Fixes #757
Signed-off-by: Silvestrs Timofejevs <silvestrst@lowrisc.org>
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
1 participant
You can’t perform that action at this time.