New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

LRM gets error on startup and wont run, regardless if fsx is running or not #2

Closed
harry8227 opened this Issue Apr 26, 2016 · 13 comments

Comments

Projects
None yet
4 participants
@harry8227

harry8227 commented Apr 26, 2016

LMR gets error on startup and wont run, regardless if fsx is running or not

@allebb

This comment has been minimized.

Contributor

allebb commented Apr 26, 2016

Any chance you could post up the error message/a screenshot of the error?

What version of Windows are you running too?

Cheers,
Bobby

@vortekc

This comment has been minimized.

vortekc commented Apr 27, 2016

I have similar problem. In the windows log i found this:
Application: LRM.exe
Framework Version: v4.0.30319
Description: The process was terminated due to an unhandled exception.
Exception Info: System.FormatException
at System.Number.StringToNumber(System.String, System.Globalization.NumberStyles, NumberBuffer ByRef, System.Globalization.NumberFormatInfo, Boolean)
at System.Number.ParseDecimal(System.String, System.Globalization.NumberStyles, System.Globalization.NumberFormatInfo)
at System.Convert.ToDecimal(System.String)
at LRM.WebServices.isNewVersionAvailable()
at LRM.MainForm.autoCheckUpdates()
at LRM.MainForm..ctor()
at LRM.Program.Main()

P.S. i am fix this by changing date and numbers format to English (US)
Turn off update check in LRM.exe.config config file help too

@gaabne

This comment has been minimized.

gaabne commented May 24, 2016

I have the same error - using Windows 7 64 - with French regionals!
When I set English (US) it works, but it cannot be a permanent solution !

Could you consider to allow for other regional setting - it would be great.
Thank you for this nice utility.

@allebb

This comment has been minimized.

Contributor

allebb commented May 25, 2016

Hey guys - Thanks for the additional reports, I'll look to get this resolved and a new version pushed ASAP.

@gaabne

This comment has been minimized.

gaabne commented Jul 15, 2016

Hello,
I just discovered that the failure on non english systems is linked to the ckeck for update option.
Turn off update check option (as well as upload landing rate) solves the issue.

I like a lot your application - I am just missing the Ground Speed at same time to help me improve my landings...

Thanks to consider that option.

@allebb allebb self-assigned this Aug 9, 2016

@allebb allebb added this to the 2.4 milestone Aug 9, 2016

@allebb

This comment has been minimized.

Contributor

allebb commented Aug 9, 2016

Evening all - Been really busy recently so I'm glad that you've been able to find a temporary work around.

Just a quick note to let you know that this will be fixed in the 2.4 release that I wil lbe releasing tomorrow.

Thanks for your patience 👍

@gaabne

This comment has been minimized.

gaabne commented Aug 10, 2016

Thank you for your note.

Would you mind, taking opportinity of this update, to add an option to display the speed at landing time ?
I known it was displayed in a previous version, but some people asked to suppress it :(
Cheers
Gérard

@allebb

This comment has been minimized.

Contributor

allebb commented Aug 10, 2016

Yeah sure thing - Would you mind openig a separate issue (well, feature request) on GitHub for this request and I will work on getting that added this evening too.

I assume you mean have it displayed on the desktop app too (instead of on the green in-sim ticker?)

I'd be more than happy to add it to the desktop app display but not keen on adding it to the flight sim ticker really especially as people didn't like too much info displayed in-sim.

Cheers,
Bobby

@allebb

This comment has been minimized.

Contributor

allebb commented Aug 10, 2016

On the other hand @gaabne ... I could, if you did want it on the green, in-sim ticker, I suppose I could add an option to the LRM tool to "Display additional stats in-sim" which could then show the IAS at landing, wind speed etc. - Just open the the other "Feature request" with your requirements and I will look to get it added this evening.

@allebb allebb changed the title from LMR gets error on startup and wont run, regardless if fsx is running or not to LRM gets error on startup and wont run, regardless if fsx is running or not Aug 10, 2016

@allebb allebb added the bug label Aug 10, 2016

@allebb

This comment has been minimized.

Contributor

allebb commented Aug 10, 2016

This has now been fixed and tested. The latest v2.4 release can be downloaded and installed from: http://lk2.in/fw

Please report back any issues but all should work fine regardless of your regional settings!

@allebb allebb closed this Aug 10, 2016

@allebb

This comment has been minimized.

Contributor

allebb commented Aug 10, 2016

@gaabne I just wondered if you have had a chance to test this as yet and if so, could you confirm it's all ok for you now?

@gaabne

This comment has been minimized.

gaabne commented Aug 10, 2016

@bobsta63
I made a quick test - everything is ok for me :)
A big big thanks

Gérard

@allebb

This comment has been minimized.

Contributor

allebb commented Aug 10, 2016

That's great - Thanks for confirming and you are very welcome 👍

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment