Permalink
Browse files

compat: use proper version check

Should work for every supported version and doesn't break in 9.6
  • Loading branch information...
1 parent c2167ae commit 4a0bf2ec93246501235964b4585786f739ddeb7f @lu-zero committed Oct 17, 2012
Showing with 2 additions and 2 deletions.
  1. +2 −2 compat.h
View
@@ -1,7 +1,7 @@
#pragma once
-#include "DeckLinkAPI.h"
+#include "DeckLinkAPIVersion.h"
-#ifdef IID_IDeckLinkVideoConversion
+#if (BLACKMAGIC_DECKLINK_API_VERSION > 0x07030000)
/* IID_IDeckLinkVideoConversion is only available in recent DeckLink SDKs,
at least 7.9 has it and 7.3 does not have it, so it's fine for now
but we might need to find a better way determining the SDK version

0 comments on commit 4a0bf2e

Please sign in to comment.