Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

Merge pull request #1 from pmq20/master

The version of dependent Mongoid can be upgraded without changes to the main code
  • Loading branch information...
commit b950ee196c028864dcaf0217e3acf7cdb93e26b5 2 parents 28d36ff + 94db897
@lucasas authored
View
2  Gemfile
@@ -4,7 +4,7 @@ source "http://rubygems.org"
gemspec
group :development do
- gem "rails", "3.0.0"
+ gem "rails", "~> 3.1.3"
end
group :test do
View
4 spec/spec_helper.rb
@@ -2,10 +2,10 @@
require 'mongoid'
require 'will_paginate'
require 'will_paginate_mongoid'
-
require File.join(File.dirname(__FILE__), 'fake_app')
require 'rspec/rails'
+
Dir["#{File.dirname(__FILE__)}/support/**/*.rb"].each {|f| require f}
RSpec.configure do |config|
@@ -18,5 +18,5 @@
end
Mongoid.configure do |config|
- config.master = Mongo::Connection.new.db("will_paginate_mongoid")
+ config.master = Mongo::Connection.new.db("will_paginate_mongoid_test")
end
View
3  will_paginate_mongoid.gemspec
@@ -18,6 +18,7 @@ Gem::Specification.new do |s|
s.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
s.require_paths = ["lib"]
- s.add_runtime_dependency "mongoid", "~> 2.2.2"
+ s.add_runtime_dependency "mongoid", "~> 2.4"
+ s.add_runtime_dependency "bson_ext", "~> 1.5"
s.add_runtime_dependency "will_paginate", "~> 3.0.2"
end

0 comments on commit b950ee1

Please sign in to comment.
Something went wrong with that request. Please try again.