Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Browse files

using bundler

  • Loading branch information...
commit b62ccda2dcadf74a11ddd7777b00baccbc10e819 1 parent 8197201
@lucasmazza authored
View
1  .gitignore
@@ -1,3 +1,4 @@
+.bundle
pkg
pkg/*
output
View
70 Rakefile
@@ -1,33 +1,45 @@
-# encoding: utf-8
-require 'rubygems'
-require 'rake'
+require 'bundler'
+require 'rspec/core/rake_task'
+Bundler::GemHelper.install_tasks
-begin
- require 'jeweler'
- Jeweler::Tasks.new do |gem|
- gem.name = "showtime"
- gem.summary = %Q{Simple Sinatra generator}
- gem.description = %Q{Application generator for simple Sinatra apps.}
- gem.email = "luc4smazza@gmail.com"
- gem.homepage = "http://github.com/lucasmazza/showtime"
- gem.authors = ["Lucas Mazza"]
- gem.add_development_dependency "rspec", ">= 1.3.0"
- gem.require_path = 'lib'
- gem.bindir = "bin"
- gem.executables = %w(showtime)
- gem.test_files.include 'spec/**/*'
- gem.add_dependency "thor", ">= 0.14.0"
- end
- Jeweler::GemcutterTasks.new
-rescue LoadError
- puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
-end
-
-require 'spec/rake/spectask'
-Spec::Rake::SpecTask.new(:spec) do |spec|
- spec.libs << 'lib' << 'spec'
- spec.spec_opts = %w(--format specdoc --color)
- spec.spec_files = FileList['spec/**/*_spec.rb']
+desc "Run specs"
+RSpec::Core::RakeTask.new do |task|
+ task.rspec_opts = ["-c"]
end
task :default => :spec
+
+#
+# # encoding: utf-8
+# require 'rubygems'
+# require 'rake'
+#
+# begin
+# require 'jeweler'
+# Jeweler::Tasks.new do |gem|
+# gem.name = "showtime"
+# gem.summary = %Q{Simple Sinatra generator}
+# gem.description = %Q{Application generator for simple Sinatra apps.}
+# gem.email = "luc4smazza@gmail.com"
+# gem.homepage = "http://github.com/lucasmazza/showtime"
+# gem.authors = ["Lucas Mazza"]
+# gem.add_development_dependency "rspec", ">= 1.3.0"
+# gem.require_path = 'lib'
+# gem.bindir = "bin"
+# gem.executables = %w(showtime)
+# gem.test_files.include 'spec/**/*'
+# gem.add_dependency "thor", ">= 0.14.0"
+# end
+# Jeweler::GemcutterTasks.new
+# rescue LoadError
+# puts "Jeweler (or a dependency) not available. Install it with: gem install jeweler"
+# end
+#
+# require 'spec/rake/spectask'
+# Spec::Rake::SpecTask.new(:spec) do |spec|
+# spec.libs << 'lib' << 'spec'
+# spec.spec_opts = %w(--format specdoc --color)
+# spec.spec_files = FileList['spec/**/*_spec.rb']
+# end
+#
+# task :default => :spec
View
1  VERSION
@@ -1 +0,0 @@
-0.1.3
View
0  bin/showtime 100644 → 100755
File mode changed
View
83 showtime.gemspec
@@ -1,73 +1,22 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
- s.name = %q{showtime}
- s.version = "0.1.3"
+ s.name = "showtime"
+ s.version = "0.1.3"
+ s.platform = Gem::Platform::RUBY
+ s.authors = ["Lucas Mazza"]
+ s.date = %q{2010-08-09}
+ s.email = ["luc4smazza@gmail.com"]
+ s.homepage = "http://rubygems.org/gems/showtime"
+ s.summary = "Simple Sinatra generator"
+ s.description = "Application generator for simple Sinatra apps"
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Lucas Mazza"]
- s.date = %q{2010-08-09}
- s.default_executable = %q{showtime}
- s.description = %q{Application generator for simple Sinatra apps.}
- s.email = %q{luc4smazza@gmail.com}
- s.executables = ["showtime"]
- s.extra_rdoc_files = [
- "LICENSE",
- "README.markdown",
- "TODO"
- ]
- s.files = [
- ".gitignore",
- "LICENSE",
- "README.markdown",
- "Rakefile",
- "TODO",
- "VERSION",
- "bin/showtime",
- "lib/showtime.rb",
- "lib/showtime/generator.rb",
- "lib/showtime/templates/.gems",
- "lib/showtime/templates/Rakefile",
- "lib/showtime/templates/application.rb",
- "lib/showtime/templates/config.ru",
- "lib/showtime/templates/public/javascripts/application.js",
- "lib/showtime/templates/public/stylesheets/application.css",
- "lib/showtime/templates/spec/application_spec.rb",
- "lib/showtime/templates/spec/spec_helper.rb",
- "lib/showtime/templates/views/index.erb",
- "showtime.gemspec",
- "spec/generator_spec.rb",
- "spec/helper_methods.rb",
- "spec/spec_helper.rb"
- ]
- s.homepage = %q{http://github.com/lucasmazza/showtime}
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
- s.summary = %q{Simple Sinatra generator}
- s.test_files = [
- "spec/generator_spec.rb",
- "spec/helper_methods.rb",
- "spec/spec_helper.rb"
- ]
+ s.required_rubygems_version = ">= 1.3.6"
+ s.add_development_dependency "bundler", ">= 1.0.0"
+ s.add_development_dependency "rspec", ">= 2.0.0"
+ s.add_runtime_dependency "thor", ">= 0.14.3"
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
-
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<rspec>, [">= 1.3.0"])
- s.add_runtime_dependency(%q<thor>, [">= 0.14.0"])
- else
- s.add_dependency(%q<rspec>, [">= 1.3.0"])
- s.add_dependency(%q<thor>, [">= 0.14.0"])
- end
- else
- s.add_dependency(%q<rspec>, [">= 1.3.0"])
- s.add_dependency(%q<thor>, [">= 0.14.0"])
- end
+ s.files = `git ls-files`.split("\n")
+ s.executables = `git ls-files`.split("\n").map{|f| f =~ /^bin\/(.*)/ ? $1 : nil}.compact
+ s.require_path = 'lib'
end
-
View
2  spec/spec_helper.rb
@@ -3,7 +3,7 @@
require 'fileutils'
require 'stringio'
-Spec::Runner.configure do |config|
+RSpec.configure do |config|
def sandbox
"./output/showtime"
Please sign in to comment.
Something went wrong with that request. Please try again.