Skip to content
Browse files

Cleanup dependencies, closes #26.

  • Loading branch information...
1 parent 13bec2c commit 5716ea088c9193e9238c382b067be3ef2952aae0 @lucassus committed
Showing with 17 additions and 20 deletions.
  1. +0 −15 Gemfile
  2. +1 −1 lib/mongo_browser/version.rb
  3. +16 −4 mongo_browser.gemspec
View
15 Gemfile
@@ -2,18 +2,3 @@ source "https://rubygems.org"
# Specify your gem's dependencies in mongo_browser.gemspec
gemspec
-
-gem "sprockets"
-gem "coffee-script"
-gem "sass"
-gem "less"
-
-group :development, :test do
- gem "rspec"
- gem "capybara"
- gem "capybara-webkit"
- gem "launchy"
- gem "simplecov"
-
- gem "debugger"
-end
View
2 lib/mongo_browser/version.rb
@@ -1,3 +1,3 @@
module MongoBrowser
- VERSION = "0.1.1"
+ VERSION = "0.1.2"
end
View
20 mongo_browser.gemspec
@@ -15,18 +15,30 @@ Gem::Specification.new do |gem|
gem.require_paths = ["lib"]
gem.version = MongoBrowser::VERSION
- gem.add_development_dependency("rdoc")
- gem.add_development_dependency("aruba")
- gem.add_development_dependency("rake", "~> 10.0.1")
+ gem.add_development_dependency("rdoc", "~> 3.12")
+ gem.add_development_dependency("aruba", "~> 0.5.1")
+ gem.add_development_dependency("rake", "~> 10.0.2")
+
+ gem.add_development_dependency("rspec", "~> 2.12.0")
+ gem.add_development_dependency("capybara", "~> 1.1.3")
+ gem.add_development_dependency("capybara-webkit", "~> 0.13.0")
+ gem.add_development_dependency("launchy", "~> 2.1.2")
+ gem.add_development_dependency("simplecov", "~> 0.7.1")
+ gem.add_development_dependency("debugger", "~> 1.2.2")
gem.add_dependency("mongo", "~> 1.7.0")
gem.add_dependency("bson_ext", "~> 1.7.0")
gem.add_dependency("methadone", "~> 1.2.2")
gem.add_dependency("foreverb", "~> 0.3.2")
+ gem.add_dependency("awesome_print", "~> 1.1.0")
+
gem.add_dependency("sinatra", "~> 1.3.3")
gem.add_dependency("sinatra-contrib", "~> 1.3.2")
gem.add_dependency("sinatra-flash", "~> 0.3.0")
gem.add_dependency("will_paginate-bootstrap", "~> 0.2.1")
gem.add_dependency("json", "~> 1.7.5")
- gem.add_dependency("awesome_print", "~> 1.1.0")
+
+ gem.add_dependency("sprockets", "~> 2.8.1")
+ gem.add_dependency("coffee-script", "~> 2.2.0")
+ gem.add_dependency("sass", "~> 3.2.3")
end

0 comments on commit 5716ea0

Please sign in to comment.
Something went wrong with that request. Please try again.