Skip to content
Deep Learning for Spatio-Temporal Data
Branch: master
Clone or download
lucktroy Update ReadMe.md
update OneDrive link
Latest commit a25bc8d Dec 11, 2017
Permalink
Type Name Latest commit message Commit time
Failed to load latest commit information.
data Update ReadMe.md Dec 11, 2017
deepst update README Dec 8, 2016
scripts/papers/AAAI17 Update README.md May 10, 2017
.gitignore update README Dec 8, 2016
LICENSE update Test Dec 8, 2016
README.md Update README.md Jan 24, 2017
keras_configuration.md Update keras_configuration.md Nov 28, 2017
setup.py update README.md Dec 8, 2016

README.md

DeepST

DeepST: A Deep Learning Toolbox for Spatio-Temporal Data

Tested on Windows Server 2012 R2.

Installation

DeepST uses the following dependencies:

  • Keras and its dependencies are required to use DeepST. Please read Keras Configuration for the configuration setting.
  • Theano or TensorFlow, but Theano is recommended.
  • numpy and scipy
  • HDF5 and h5py
  • pandas
  • CUDA 7.5 or latest version. And cuDNN is highly recommended.

To install DeepST, cd to the DeepST folder and run the install command:

python setup.py install

To install the development version:

python setup.py develop

Data path

The default DATAPATH variable is DATAPATH=[path_to_DeepST]/data. You may set your DATAPATH variable using

# Windows
set DATAPATH=[path_to_your_data]

# Linux
export DATAPATH=[path_to_your_data]

License

DeepST is released under the MIT License (refer to the LICENSE file for details).

You can’t perform that action at this time.