Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Update to latest bundler procedure.

Eliminate dependencies that break installing the gem via bundler and/or rvm.
Add sprout dependency.
Bump version.
  • Loading branch information...
commit c34fcb1990d143f95fe892b4142360d9f59e88a5 1 parent f4eff6b
@apinstein apinstein authored
Showing with 6 additions and 5 deletions.
  1. +1 −1  VERSION
  2. +5 −4 flashsdk.gemspec
View
2  VERSION
@@ -1 +1 @@
-1.0.29.pre
+1.0.30.pre
View
9 flashsdk.gemspec
@@ -1,9 +1,9 @@
# -*- encoding: utf-8 -*-
-lib = File.expand_path File.dirname(__FILE__), 'lib'
+lib = File.expand_path('../lib/', __FILE__)
$:.unshift lib unless $:.include?(lib)
require 'bundler'
-require 'flashsdk'
+require 'flashsdk/module.rb'
Gem::Specification.new do |s|
s.name = 'flashsdk'
@@ -15,8 +15,9 @@ Gem::Specification.new do |s|
s.description = "The Flash SDK Rubygem is brought to you by Project Sprouts (http://projectsprouts.org)"
s.executables = ['sprout-as3', 'sprout-flex', 'flashplayer', 'flashlog']
s.post_install_message = File.read 'POSTINSTALL.rdoc'
- s.files = FileList['**/**/*'].exclude /.git|.svn|.DS_Store/
- s.add_bundler_dependencies
+ s.files = Dir['**/*']
+ s.files.reject! { |fn| fn.match /.git|.svn|.DS_Store/ }
+ s.add_dependency('sprout', '>= 1.0.0.pre')
s.require_paths << 'lib'
end
Please sign in to comment.
Something went wrong with that request. Please try again.