Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP
Branch: develop
Fetching contributors…

Cannot retrieve contributors at this time

55 lines (50 sloc) 2.187 kB
# -*- encoding: utf-8 -*-
Gem::Specification.new do |s|
s.name = "mimic"
s.version = "0.4.3"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Luke Redpath"]
s.date = "2012-03-17"
s.email = "luke@lukeredpath.co.uk"
s.extra_rdoc_files = ["README.md"]
s.files = ["LICENSE", "CHANGES", "Rakefile", "README.md", "spec", "lib/mimic", "lib/mimic/api.rb", "lib/mimic/fake_host.rb", "lib/mimic.rb"]
s.homepage = "http://lukeredpath.co.uk"
s.rdoc_options = ["--main", "README.md"]
s.require_paths = ["lib"]
s.rubygems_version = "1.8.11"
s.summary = "A Ruby gem for faking external web services for testing"
if s.respond_to? :specification_version then
s.specification_version = 3
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<rack>, [">= 0"])
s.add_runtime_dependency(%q<sinatra>, [">= 0"])
s.add_runtime_dependency(%q<thin>, [">= 0"])
s.add_runtime_dependency(%q<json>, [">= 0"])
s.add_runtime_dependency(%q<plist>, ["~> 3.1.0"])
s.add_development_dependency(%q<rspec>, ["~> 2.4.0"])
s.add_development_dependency(%q<cucumber>, [">= 0"])
s.add_development_dependency(%q<mocha>, [">= 0"])
s.add_development_dependency(%q<rest-client>, [">= 0"])
else
s.add_dependency(%q<rack>, [">= 0"])
s.add_dependency(%q<sinatra>, [">= 0"])
s.add_dependency(%q<thin>, [">= 0"])
s.add_dependency(%q<json>, [">= 0"])
s.add_dependency(%q<plist>, ["~> 3.1.0"])
s.add_dependency(%q<rspec>, ["~> 2.4.0"])
s.add_dependency(%q<cucumber>, [">= 0"])
s.add_dependency(%q<mocha>, [">= 0"])
s.add_dependency(%q<rest-client>, [">= 0"])
end
else
s.add_dependency(%q<rack>, [">= 0"])
s.add_dependency(%q<sinatra>, [">= 0"])
s.add_dependency(%q<thin>, [">= 0"])
s.add_dependency(%q<json>, [">= 0"])
s.add_dependency(%q<plist>, ["~> 3.1.0"])
s.add_dependency(%q<rspec>, ["~> 2.4.0"])
s.add_dependency(%q<cucumber>, [">= 0"])
s.add_dependency(%q<mocha>, [">= 0"])
s.add_dependency(%q<rest-client>, [">= 0"])
end
end
Jump to Line
Something went wrong with that request. Please try again.