Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

First commit

  • Loading branch information...
commit 8831780440ffcd7797ecd03f15f972cc1e47e2b7 0 parents
@Doppp Doppp authored
7 .gitignore
@@ -0,0 +1,7 @@
+.bundle/
+log/*.log
+pkg/
+spec/dummy/db/*.sqlite3
+spec/dummy/log/*.log
+spec/dummy/tmp/
+spec/dummy/.sass-cache
17 Gemfile
@@ -0,0 +1,17 @@
+source "http://rubygems.org"
+
+# Declare your gem's dependencies in campystrano.gemspec.
@azach Owner
azach added a note

hmmmmmmmmmm

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
+# Bundler will treat runtime dependencies like base dependencies, and
+# development dependencies will be added by default to the :development group.
+gemspec
+
+# jquery-rails is used by the dummy application
+gem "jquery-rails"
+
+# Declare any dependencies that are still in development here instead of in
+# your gemspec. These might include edge Rails or gems from your path or
+# Git. Remember to move these dependencies to your gemspec before releasing
+# your gem to rubygems.org.
+
+# To use debugger
+# gem 'debugger'
111 Gemfile.lock
@@ -0,0 +1,111 @@
+PATH
+ remote: .
+ specs:
+ paxmex (0.0.1)
+ rails (~> 3.2.12)
+
+GEM
+ remote: http://rubygems.org/
+ specs:
+ actionmailer (3.2.12)
+ actionpack (= 3.2.12)
+ mail (~> 2.4.4)
+ actionpack (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
+ builder (~> 3.0.0)
+ erubis (~> 2.7.0)
+ journey (~> 1.0.4)
+ rack (~> 1.4.5)
+ rack-cache (~> 1.2)
+ rack-test (~> 0.6.1)
+ sprockets (~> 2.2.1)
+ activemodel (3.2.12)
+ activesupport (= 3.2.12)
+ builder (~> 3.0.0)
+ activerecord (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
+ arel (~> 3.0.2)
+ tzinfo (~> 0.3.29)
+ activeresource (3.2.12)
+ activemodel (= 3.2.12)
+ activesupport (= 3.2.12)
+ activesupport (3.2.12)
+ i18n (~> 0.6)
+ multi_json (~> 1.0)
+ arel (3.0.2)
+ builder (3.0.4)
+ diff-lcs (1.1.3)
+ erubis (2.7.0)
+ hike (1.2.1)
+ i18n (0.6.1)
+ journey (1.0.4)
+ jquery-rails (2.2.1)
+ railties (>= 3.0, < 5.0)
+ thor (>= 0.14, < 2.0)
+ json (1.7.7)
+ mail (2.4.4)
+ i18n (>= 0.4.0)
+ mime-types (~> 1.16)
+ treetop (~> 1.4.8)
+ mime-types (1.21)
+ multi_json (1.6.1)
+ polyglot (0.3.3)
+ rack (1.4.5)
+ rack-cache (1.2)
+ rack (>= 0.4)
+ rack-ssl (1.3.3)
+ rack
+ rack-test (0.6.2)
+ rack (>= 1.0)
+ rails (3.2.12)
+ actionmailer (= 3.2.12)
+ actionpack (= 3.2.12)
+ activerecord (= 3.2.12)
+ activeresource (= 3.2.12)
+ activesupport (= 3.2.12)
+ bundler (~> 1.0)
+ railties (= 3.2.12)
+ railties (3.2.12)
+ actionpack (= 3.2.12)
+ activesupport (= 3.2.12)
+ rack-ssl (~> 1.3.2)
+ rake (>= 0.8.7)
+ rdoc (~> 3.4)
+ thor (>= 0.14.6, < 2.0)
+ rake (10.0.3)
+ rdoc (3.12.1)
+ json (~> 1.4)
+ rspec-core (2.12.2)
+ rspec-expectations (2.12.1)
+ diff-lcs (~> 1.1.3)
+ rspec-mocks (2.12.2)
+ rspec-rails (2.12.2)
+ actionpack (>= 3.0)
+ activesupport (>= 3.0)
+ railties (>= 3.0)
+ rspec-core (~> 2.12.0)
+ rspec-expectations (~> 2.12.0)
+ rspec-mocks (~> 2.12.0)
+ sprockets (2.2.2)
+ hike (~> 1.2)
+ multi_json (~> 1.0)
+ rack (~> 1.0)
+ tilt (~> 1.1, != 1.3.0)
+ sqlite3 (1.3.7)
+ thor (0.17.0)
+ tilt (1.3.3)
+ treetop (1.4.12)
+ polyglot
+ polyglot (>= 0.3.1)
+ tzinfo (0.3.35)
+
+PLATFORMS
+ ruby
+
+DEPENDENCIES
+ paxmex!
+ jquery-rails
+ rspec-rails
+ sqlite3
3  README.md
@@ -0,0 +1,3 @@
+# Paxmex
+
+This gem parses your Amex data files into human readable data.
26 Rakefile
@@ -0,0 +1,26 @@
+#!/usr/bin/env rake
+begin
+ require 'bundler/setup'
+rescue LoadError
+ puts 'You must `gem install bundler` and `bundle install` to run rake tasks'
+end
+begin
+ require 'rdoc/task'
+rescue LoadError
+ require 'rdoc/rdoc'
+ require 'rake/rdoctask'
+ RDoc::Task = Rake::RDocTask
+end
+
+RDoc::Task.new(:rdoc) do |rdoc|
+ rdoc.rdoc_dir = 'rdoc'
+ rdoc.title = 'Paxmex'
+ rdoc.options << '--line-numbers'
+ rdoc.rdoc_files.include('README.rdoc')
+ rdoc.rdoc_files.include('lib/**/*.rb')
+end
+
+
+
+
+Bundler::GemHelper.install_tasks
2  lib/paxmex.rb
@@ -0,0 +1,2 @@
+module Paxmex
+end
3  lib/paxmex/version.rb
@@ -0,0 +1,3 @@
+module Paxmex
+ VERSION = "0.0.1"
+end
4 lib/tasks/paxmex_tasks.rake
@@ -0,0 +1,4 @@
+desc "Explaining what the task does"
+task :paxmex do
+ # Task goes here
+end
22 paxmex.gemspec
@@ -0,0 +1,22 @@
+$:.push File.expand_path("../lib", __FILE__)
+
+# Maintain your gem's version:
+require "paxmex/version"
+
+# Describe your gem and declare its dependencies:
+Gem::Specification.new do |s|
+ s.name = "paxmex"
+ s.version = Paxmex::VERSION
+ s.authors = ["Daryl Yeo", "Anthony Zacharakis"]
+ s.email = ["daryl@lumoslabs.com"]
+ s.homepage = "https://github.com/lumoslabs/paxmex"
+ s.summary = "This gem parses your Amex data files into human readable data.."
@azach Owner
azach added a note

Extra period typo

@azach Owner
azach added a note

Extra period typo

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
+ s.description = "TODO: Description."
@azach Owner
azach added a note

Remove or enter description for valid gemspec

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
+
+ s.files = Dir["{app,config,db,lib}/**/*"] + ["MIT-LICENSE", "Rakefile", "README.rdoc"]
@azach Owner
azach added a note

All these files should either exist or be removed (otherwise it won't be a valid gemspec). Let's add the license and rename README.rdoc to README.md

@azach Owner
azach added a note

All these files should either exist or be removed (otherwise it won't be a valid gemspec). Let's add the license and rename README.rdoc to README.md

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
+
+ s.add_dependency "rails", "~> 3.2.12"
+
+ s.add_development_dependency "sqlite3"
+ s.add_development_dependency "rspec-rails"
+end
@azach
Owner

hmmmmmmmmmm

@azach

All these files should either exist or be removed (otherwise it won't be a valid gemspec). Let's add the license and rename README.rdoc to README.md

@azach

All these files should either exist or be removed (otherwise it won't be a valid gemspec). Let's add the license and rename README.rdoc to README.md

@azach

Remove or enter description for valid gemspec

@azach

Extra period typo

@azach

Extra period typo

Please sign in to comment.
Something went wrong with that request. Please try again.