Skip to content
Browse files

systemd: fix dependencies

Dependency list was a bit out of date.

usbutils caused a depdenency loop, usbutils and pciutils is no longer
a direct dependency. Since version 196 systemd ships its own
hwdb for pci and usb.
  • Loading branch information...
1 parent a3d576d commit 92a37e59145caba06fab5fbbc3295d3f8c3d6ee2 @Ratler Ratler committed
Showing with 6 additions and 2 deletions.
  1. +6 −2 system/systemd/DEPENDS
View
8 system/systemd/DEPENDS
@@ -1,12 +1,16 @@
depends kmod
depends dbus
depends libcap
-depends usbutils
-depends pciutils
depends intltool
depends gperf
+depends xz
+depends util-linux
+optional_depends "acl" "--enable-acl" "--disable-acl" "for ACL support"
+optional_depends "attr" "--enable-xattr" "--disable-xattr" "for extended fs attributes support"
optional_depends "cryptsetup" "--enable-libcryptsetup" "--disable-libcryptsetup" "for Device-mapper crypto encryption"
optional_depends "Linux-PAM" "--with-pamlibdir=/lib/security" "--disable-pam" "for PAM support"
optional_depends "docbook-xsl" "" "--disable-manpages" "for manpages"
optional_depends "docbook-xml" "" "--disable-manpages" "for manpages"
+optional_depends "glib-2" "--enable-gudev" "--disable-gudev" "for Gobject libudev support"
+optional_depends "libgcrypt" "--enable-gcrypt" "--disable-gcrypt" "for gcrypt support"

0 comments on commit 92a37e5

Please sign in to comment.
Something went wrong with that request. Please try again.