Permalink
Browse files

firefox: SMP build enabled, fixes for libvpx 1.0, other fixes

  • Loading branch information...
1 parent 22bcd9f commit 2356556cad873576426c95b16b90fc617aa767ce Zbigniew Luszpinski committed Feb 11, 2012
Showing with 10 additions and 8 deletions.
  1. +7 −2 web/firefox/BUILD
  2. +0 −3 web/firefox/DEPENDS
  3. +1 −1 web/firefox/DETAILS
  4. +1 −1 web/firefox/PRE_BUILD
  5. +1 −1 web/firefox/mozconfig
View
@@ -6,15 +6,20 @@
sedit 's/@PRE_RELEASE_SUFFIX@//g' browser/base/content/browser.xul &&
if module_is_expired $MODULE && [ "$VERSION" != "`installed_version $MODULE`" ]; then
- set_module_config OLD_VER "`installed_version $MODULE`"
+ set_module_config OLD_VER "`installed_version $MODULE`"
fi &&
+ # Adds support for libvpx 1.0. Later firefox will have this fix so remove this then.
+ sedit 's/VPX_CODEC_USE_INPUT_PARTITION/VPX_CODEC_USE_INPUT_FRAGMENTS/' configure &&
+ sedit 's/v0\.9\.7/v1.0.0/' configure &&
+
export MOZ_CO_PROJECT=browser &&
+ export MOZILLA_HOME=/usr/lib/$MODULE-$VERSION &&
export MOZILLA_OFFICIAL=1 &&
export BUILD_OFFICIAL=1 &&
+ export MOZ_MAKE_FILES=$MAKES &&
cp $SCRIPT_DIRECTORY/mozconfig . &&
-
export MOZ_OBJDIR="${SOURCE_DIRECTORY}/build-mozilla" &&
mkdir -p ${MOZ_OBJDIR} &&
View
@@ -23,6 +23,3 @@ optional_depends "hunspell" "" "" "For spelling support"
# $OPTS is ignored in this BUILD
optional_depends "libevent" "" "" "For event detection"
optional_depends "dbus-glib" "" "" "For dbus support"
-
-optional_depends " libvpx" "--with-system-libvpx" "" "for vpx support"
-
View
@@ -1,6 +1,6 @@
MODULE=firefox
VERSION=10.0.1
- SOURCE=firefox-$VERSION.source.tar.bz2
+ SOURCE=$MODULE-$VERSION.source.tar.bz2
SOURCE_URL[0]=ftp://ftp.uni-erlangen.de/pub/mozilla.org/firefox/releases/$VERSION/source
SOURCE_URL[1]=ftp://mozilla.isc.org/pub/mozilla.org/firefox/releases/$VERSION/source
SOURCE_URL[2]=ftp://ftp.mozilla.org/pub/firefox/releases/$VERSION/source
@@ -1,6 +1,6 @@
if [ ! -e /usr/include/cairo/cairo-tee.h ] ; then
message "${PROBLEM_COLOR}Run: ${MODULE_COLOR}lin -c cairo"
- message "${MESSAGE_COLOR}To recompile cairo with tee support, which is required by firefox6.${DEFAULT_COLOR}"
+ message "${MESSAGE_COLOR}To recompile cairo with tee support, which is required by firefox.${DEFAULT_COLOR}"
exit 1
fi
@@ -30,7 +30,7 @@ ac_add_options --enable-mathml
ac_add_options --disable-os2-high-mem
ac_add_options --enable-gio
ac_add_options --enable-raw
+ac_add_options --with-system-libvpx
ac_add_options --enable-splashscreen
-ac_add_options --enable-url-classifier
ac_add_options --enable-shared-js
ac_add_options --enable-system-pixman

0 comments on commit 2356556

Please sign in to comment.