Skip to content
Browse files

spidermonkey: reinstate installing the command-line "js" interpreter

For some reason, 1.8.x of spidermonkey doesn't install the REPL in
/usr/bin/js any more like previous versions did.  This is probably a bug
which will be fixed presently, rendering this a temporary workaround.
  • Loading branch information...
1 parent 02ffd41 commit a21edc9f0f9dca4ace414f19e8cc1a7a5829a915 @dagbrown dagbrown committed
Showing with 5 additions and 1 deletion.
  1. +5 −1 libs/spidermonkey/BUILD
View
6 libs/spidermonkey/BUILD
@@ -9,6 +9,10 @@
default_build &&
#for backwards compatibility
- ln -sf /usr/lib/libmozjs${VERSION%\.*}.a /usr/lib/libjs_static.a
+ ln -sf /usr/lib/libmozjs${VERSION%\.*}.a /usr/lib/libjs_static.a &&
+
+ # because spidermonkey 1.8.5 seems to have stopped installing the REPL
+
+ install -m 755 shell/js /usr/bin
) > $C_FIFO 2>&1

0 comments on commit a21edc9

Please sign in to comment.
Something went wrong with that request. Please try again.